Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 15 of 15 Posts

·
Registered
2001 Wrangler Sport
Joined
·
4,645 Posts
NCCoumbe said:
Why does it always seem like my oil pressure is high? I just did another oil change and it still stays as high as in this pic. Any ideas?
That's normal, mine runs that and a bit higher at speed.
 

·
Knows a couple things...
Joined
·
49,627 Posts
Newer TJ oil pressure gauges have been programmed to never show the normal ups and downs of oil pressure which was scaring some owners. So long as the oil pressure is ok in a newer TJ, the computer will always show a mid-scale reading.

Assuming of course your TJ is newer... I think they reprogrammed it 2001-2002 or so. Older TJs do show a fairly accurate oil pressure so long as the right oil pressure sender has been installed.
 

·
Commercial Member
Joined
·
3,962 Posts
Looks like you are not up to temperature yet, mine stays about the same as yours while idling until the oil gets good and hot for a while, but then it starts showing about 60 at speed and 20 when idling
 

·
Registered
Joined
·
41 Posts
I've got a '97 and mine does the same thing. In fact, mine goes higher than that while I'm driving ... never had any problems with that though.
 

·
Registered
Joined
·
768 Posts
Yea that's normal, does it drop a little at idle when fully warm? If you think you have some sludging/blockage synthetic oil will clean it out...autoRX additive works really good too. But it looks ok..
 

·
Knows a couple things...
Joined
·
49,627 Posts
Unusual your '97 does that which if the pressure gauge doesn't drop down at idle RPMs makes me believe someone may have installed an oil pressure sensor meant for a newer model TJ. My '97 TJ's oil pressure gauge varied up and down in step with engine RPMs as it should have.

Also, what viscosity oil is in your engine? Too high of a viscosity can create an abnormally high oil pressure indication.
 

·
Commercial Member
Joined
·
3,962 Posts
Jerry Bransford said:
Unusual your '97 does that which if the pressure gauge doesn't drop down at idle RPMs makes me believe someone may have installed an oil pressure sensor meant for a newer model TJ. My '97 TJ's oil pressure gauge varied up and down in step with engine RPMs as it should have.
Same as my '00
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #11 ·
Jerry Bransford said:
Unusual your '97 does that which if the pressure gauge doesn't drop down at idle RPMs makes me believe someone may have installed an oil pressure sensor meant for a newer model TJ. My '97 TJ's oil pressure gauge varied up and down in step with engine RPMs as it should have.

Also, what viscosity oil is in your engine? Too high of a viscosity can create an abnormally high oil pressure indication.
I have 5w-30 with Lucas oil stabilizer.
 

·
Knows a couple things...
Joined
·
49,627 Posts
Probably the wrong oil pressure sender then if your oil pressure never drops below midscale. I would DEFINITELY DEFINITELY DEFINITELY not run Lucas "oil stabilizer" in any engine oil, gear lube, transmission, nothin'. Additives generally do nothing but degrade the performance of modern multiweight engine oils and gear lubes... especially Lucas Oil Stabilizer which has been shown to encourage the oil to trap air and turn into a frothy mess.

Each and every major oil manufacturer recommends additives not be added, their careful blends of additives and chemicals would only be screwed up with some catch-all additive the oil doesn't need or is helped by in the least. Really.
 

·
Registered
Joined
·
3,136 Posts
I tried Lucas in one of my Dauntless V6's (that's a factory installed Buick V6 1966-1971 Jeep CJ's for you Jeep newbies) that had a ticking lifter. Twice after a long highway run (4.88's and 33's, before I installed the overdrive) when I slowed down to idle all the lifters clattered like mad, as in they wouldn't stay pumped up. I changed the oil, going back to straight Castrol 10W30, and it never happened again.
 

·
Registered
Joined
·
1 Posts
I have a 2000 jeep wrangler and i went mudding last weekend, we wash the motor and the jeep but the following day i started and the oil pressure went too high and blow the oil filter ring. I installed a new filter add oil and when started did the same, the oil pressure is too high and damage the oil filter again. I change the filter but i started with low oil and the pressure is on 80.
Any ideas
 

·
Registered
Joined
·
150 Posts
I bought my 99 3 months ago and the pressure has consistently been between 40-50...never higher, never lower. I changed the oil yesterday and it's now at 60.

Any idea what could be causing this? Thanks!
 
1 - 15 of 15 Posts
Top