Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 11 of 11 Posts

·
Registered
Joined
·
542 Posts
Discussion Starter · #1 ·
Purchased my jeep with no front driveshaft due to lift and body lift.. Owner took it out... Bought a Novak cable, and a used junkyard shaft, now at highway speed I get a crazy vibration... Any solutions?
 

·
Registered
Joined
·
3,196 Posts
Do you have a SYE or transfer case drop? How big is the lift? My guess is that the junkyard shaft is out of balance. The rear driveshaft would be the shaft that is most affected because of a lift, simply because it is so much shorter, and changing the height has a huge change of driveshaft angle. If the rear driveshaft has no vibrations, the front should have no problems at all unless the pinion angle is totally wrong in the front (ie the previous owner got aftermarket control arms) Have you checked to make sure the front and rear gears are the same? Post some pictures of front and back axles and their angles.
 

·
Registered
Joined
·
47 Posts
no vibration without the front driveshaft? If so, may just be that its not balanced. Like tires, driveshafts do need to balanced and can cause vibrations when they arent.
 

·
Registered
Joined
·
12,000 Posts
Did you replace the U joints in the junkyard drive shaft before you installed it?

Different gear ratios front and rear would only be a problem if you were using 4wd
 

·
Premium Member
Joined
·
898 Posts
All of the above.Also did junky drive shaft have any weights welded to it.They look like small square additional pieces spot welded to different areas on the shaft or look for areas where their was evidence of one.
 

·
Registered
Joined
·
542 Posts
Discussion Starter · #7 ·
All good points. Thank you.. Shaft did have weights wielded on.. And it had no vibration without the shaft in.. My u joints are in good shape and have no play. I think it just needs balance. I'll take it to the driveshaft shop and have them balance it
 

·
Registered
Joined
·
542 Posts
Discussion Starter · #8 ·
At 50 mph, no vibration. 55-65 huge vibration
 

·
Registered
Joined
·
542 Posts
Discussion Starter · #10 ·
dale 3 said:
One bad tire can be a problem?
Obviously it's not a tire -_- as I just explained without the shaft it's fine. With it it vibrates
 
1 - 11 of 11 Posts
Top