Jeep Wrangler Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
I've read all of them before, You been asked about it a thousand times. I just can't figure it out!
I have a 90 yj with a 4.2l with a Multipoint Fuel Injection Kit installed. The manual said "tune up procedures and engine servire are the same as a 1994/95 4.0 liter wrangler" due to fact that it now has a PCM.
The promblem; NO SPARK & NO FUEL !
I checked & changed everything but the PCM. Company said it highly unlikely the PCM.
Is there something I'm unawear of, a trick, a secret, a part? Anyone up for the challange? Please, no matter how stupid it sounds, any susgestion I will take.
 

·
Registered
Joined
·
5,152 Posts
I have an answer, but what do I win?

I'd send the PCM in to be checked...just b/c its highly unlikely doesn't mean its impossible. And if you've truely checked/changed out everything else, then logic would tell you its likely the PCM (ignoring what the manufacturer says)

Is PCM getting power?

You know what ACT (the clutch manufacturer) told me? that I must have installed a clutch disc in backwards when I had an issue with it not working after the install...After I argued with them I took the vehicle to a friend who owns a transmission shop. he took it apart and said it was done right...so we compared the old vs new, and the new clutch disc's center part (the name is escaping me so I'll call it a collar) was a cpl mm too long, he machined it down, and threw it back together, and ta-da it worked.

ACT told me I was wrong, and that the "expert" was wrong, and a bunch more BS. after that I'll never buy a clutch from them again. reason for my story? to back up my theory that manufacturers are wrong every once in awhile, and they resist admitting it.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #6
Thanks all. I think it's the PCM also, even if the experts tell me problely not.
The kit is from HESCO! Do you know anything about these guys? Already bought a new Crankshaft Position Censor from them and asked if I could of gotten a bad one or damage during shipping. They said it highly unlikely! Can somone tell me how to test the censor? Keep in mind the motor won't start. I'm going to throw in a new cam position censor, its the only thing that not new besides a PCM.
Keep the sugestion coming! I know there someone out there that knows something we're all missing.
 

·
Registered
Joined
·
11 Posts
I have recently installed the HESCO MPI kit on a 88' with a 4.2L. No fuel and no spark, tells me NO POWER. When you first turn the key, does the fuel pump run for a second to bring pressure up on fuel rail? If not, then I would think it to be power. The red power wire to the PCM has an in-line fuse holder in my harness from HESCO. Did you check the fuse in this holder? This red wire is the sole power for the PCM. Good Luck!
 

·
Registered
Joined
·
372 Posts
1 - 10 of 10 Posts
Top