Jeep Wrangler Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
15 Posts
i need an early 99 jeep tj ecu.... mine got fried today in the huge snow storm... it got wet and is no good! any help would be appreciated.... dealer wants 700 bucks! help a fellow jeeper out guys!
my email is [email protected]

let me know!
-dave
whats the ecu code on the tag? I may have what you need.
 

·
Registered
Joined
·
15 Posts
Yea, there should be a long number on the back of it. what is the entire thing. post a pic, or email me a pic. that would make it easier to figure it out instead of having you type the whole thing out.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #7 ·
ok there is a "motorola s/n" and a "chrysler p/n" and one other number i cant think of right now... i will just take a pic of it and post it up on here or try typin it up tomorrow... i iwll try givin you a call tomorrow joe at your place... about how much does an ecu run?
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #8 ·
is it common for these to just "quit" i mean i was driving for like 5 minutes and then it just shut off. i have power to my headlights and blower motor. but no power to dash cluster or radio. jeep wont crank not even a click. battery test out fine. checked all connections. everything is tight. but i did notice the weather stripping near the ecu had fallen down and that night we had snow/rain and there was ice buildup on the 3 connections. i got it towed to my work where it sat in a heated garage for about 4 hours. and still nothing... anyone think otherwise that the ECU is dead?
 

·
Registered
Joined
·
15 Posts
I went and looked at it and the chrysler p/n is the same as yours. I could not get my spare harness off of it to be able to read the motorola, and module numbers, but if the chrysler p/n is the same, it should be the same all throughout. it's cold and darm in my garage right now, but tomorrow, I will double check to make sure. send me an email at [email protected] and we'll work out a deal ok?
 

·
Registered
Joined
·
99 Posts
is it common for these to just "quit" i mean i was driving for like 5 minutes and then it just shut off. i have power to my headlights and blower motor. but no power to dash cluster or radio. jeep wont crank not even a click. battery test out fine. checked all connections. everything is tight. but i did notice the weather stripping near the ecu had fallen down and that night we had snow/rain and there was ice buildup on the 3 connections. i got it towed to my work where it sat in a heated garage for about 4 hours. and still nothing... anyone think otherwise that the ECU is dead?
My 89 Wrangler did the same thing.new unit fixed it.
 

·
Registered
Joined
·
4 Posts
Hi

I know that this is reviving a massively old thread, but I'm after a PCM/ECU for a 97 TJ (4l manual) and this looked like being the best thread that I could find.

I've emailed Jordas, but the Absolute Offroad web site seems to have disappeared and I wondered whether anyone had any other good suggestions. I would need it shipped to the UK.

It's not urgent, but I want to swap out my PCM for a US spec one so I can get rid of the sucky immobiliser that got fitted to all the UK models.

Thanks for your help!
 
1 - 17 of 17 Posts
Top