Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 3 of 3 Posts

·
Registered
Joined
·
513 Posts
Discussion Starter · #1 ·
So I had an issue where my Jeep wouldn't start a couple of months ago and I discovered it was a bad IAC valve so I replaced it with a brand new one. I was careful to make sure it was installed to the proper specs and since it is like a medicine cap in that you have to push down and twist to get it to the right length I made extra sure it was properly seated before I installed it. The problem is twice since then the Jeep had the exact same non-starting symptoms and when I pulled the IAC I found that it had sprung out of spec. I then reset and reinstalled it and it starts right up. The Jeep like all Jeeps drives like a tank over bumps so it gets a lot of vibration but obviously that shouldn't cause the valve to spring open and when the problem happens it's always after it was parked earlier in the day when it ran fine.

What could be causing this? It's a brand new valve but could it be faulty? I keep a set of tools in the glovebox and am able to remove, reset, and replace it in 5 minutes flat now but I don't want to have to worry about it if my wife decides to drive it. Thanks for any advice you can share.
 

·
Registered
Joined
·
496 Posts
is this an OEM IAC? if not it may be faulty out of box(OEM"s do this too sometimes). i'm pretty sure you have to pull the battery for a few to reset the board. once you start it up let it idle for a few minutes. i beleive the IAC is set for any position but upon first startup will "plunge" itself either full open or full closed to find a "true" starting point. pull the battery for a few and when you go to start it up just let it idle for a few minutes. don't hit the gas or anything. this might help
 

·
Registered
Joined
·
513 Posts
Discussion Starter · #3 ·
Hadn't thought about pulling the battery so I'll give that a shot but I will say that the idle is always the same right off the bat. If it happens again I'll return it since I still have the receipt (it's not OEM). Thanks!
 
1 - 3 of 3 Posts
Top