Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of MAY's Ride of the Month Challenge!

21 - 25 of 25 Posts

·
RETIRED MODERATOR
Joined
·
94,861 Posts
Welcome to the Forum, from Cave Creek AZ.
 

·
Registered
Joined
·
10 Posts
Thanks Old Dogger!

Hey, maybe someone can help me out, I'm trying to figure out how to add the description of my Jeep below the post. Anyone?
 

·
Registered
Joined
·
2 Posts
I said the PO did poor maintenance because there were so many simultaneous bad sensors when I got it. It ran very poorly, couldn't go much over 45 mph on the freeway (and there was a headwind). Idle varied between 700 to 1500 erratically. The Idle Air Control (IAC) was very dirty, I pulled it and cleaned it thoroughly and also inside the throttle bottle where it mounted. The idle improved but still not stable. I removed and did a resistance check on the TPS, it was very erratic as I moved it off the idle position, replaced it with new. Then I replaced the EGR, new plugs, distributor cap, rotor and wires. Reset the timing to 8-10 BTDC. Then finally replaced the O2 sensor. The engine check light went out with that sensor, and it began running good, passed Calif smog with flying colors. Didn't have to change the Cat. Oh, there were a couple of vacuum hoses connected to wrong ports. Also replaced the coolant temperature override (CTO) just for grins. The takeaway -- as soon as you notice a change in how it runs, zero in on what is failing and fix it, don't wait until it barely runs...
Thanks for clarifying
 

·
Super Moderator
Joined
·
12,457 Posts
Thanks Old Dogger!

Hey, maybe someone can help me out, I'm trying to figure out how to add the description of my Jeep below the post. Anyone?
On the forum main page, click on your avatar in the top right corner. Then click on the bottom link, "Account Settings". Then, on the left side of the screen, click on "Signature".
Fill in the dialog box with the Jeep's description. Don't forget to add all the mods that you know about.

Good Luck, L.M.
 

·
Registered
Joined
·
10 Posts
Thanks LM, never thought to go to account settings, I was roaming around the profile. We'll see if I was successful.
 
21 - 25 of 25 Posts
Top