Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
177 Posts
Discussion Starter · #1 ·
A search here gives me plenty of CEL info, but nothing that seems to be exactly what I need.

The patient is the wife's 2006 Wrangler X, all stock with 220,XXX miles, so it's starting to get broken in.

Chasing a couple of codes (p0431, p0058 if that matters...and I'm not sure it should...), I noticed that the check engine lamp doesn't come on when the key is turned to the "Run," position like I think it should. What I think is the bigger issue is I thought OBD2 should turn the lamp on any time the key is set to run.

If I blip the key to turn the starter, but not enough to start the engine, it'll come on...if I start the engine, the lamp will come on, then shut off (If the codes are reset...with codes, it'll obviously stay on) as it should.

Even my code reader will stall if I try to read codes with the key to run with no CEL...bumping the starter (as mentioned before this will turn the lamp on) will allow me to pull codes with "Key on, engine off," and pulling codes with the engine running works fine as well.

Am I missing something here, or is there an issue?

Oddly enough, when I ask Jeeves he seems to get confused about why this would happen, and my daily driver is from 1979 and I can't really compare it's engine warning lamps to the Jeeps.

Thanks in advance!
 

·
Registered
Joined
·
35 Posts
It is strange that you have to bump the key a little bit so your scanner can start reading codes for you. I would probably start by checking the connections to the Key Ignition for loose wires to the switch and the switch it's self.

As for the codes, P0058 is an O2 sensor code, bank 2 Sensor 2 I do believe. It can be the O2 sensor itself, Short to voltage, Open circuit in the connector or wire harness, or in extreme cases, the PCM.

Now for the other code, P0431, sounds like you have an issue with a catalytic converter.
 

·
Registered
Joined
·
177 Posts
Discussion Starter · #3 ·
After doing a little thinking about the CEL issue, I've convinced myself that it must be either some wear in the key cylinder or a loose connection. It's out of town right now, so I am anxiously waiting for it to get back.

I don't think it'll pass inspection with a light that works like that.

Thanks!
 

·
Registered
Joined
·
177 Posts
Discussion Starter · #4 ·
I thought I'd bump this to see if I can get more info.

The check engine lamp is still acting wonky.

The Jeep is back here for now, in and out of town. It's still throwing an intermittent p0431 that I reset when it comes on for now; some troubleshooting with a thermometer seems to show that all 3 cats have the same temp in as out, so I think that a Y-pipe replacement is in the near future.

BE that as it may, when the CEL comes on and the p0431 code is in the system I still have the same issue with the CEL. To reiterate, when I reset the code and the computer hasn't gone through enough checks/cycles/whatever to cause a retained code, the CEL comes on when the key is turned on with the engine off...meaning it'll pass an inspection and works properly.

When the p0431 code is either pending or present, and the CEL is on while the engine runs, the CEL fails to light up when the key is on, engine off, regardless of how I wiggle the lock cylinder.

While I have the p0431 code, if I turn the key on, without starting the engine, after about 1 min (Give or take) the lamp will come on.

It's not making sense to me. If the CEL doesn't come on with the key on engine off it should mean either worn components between the key and computer or a bad computer...but since when I clear the codes they CEL comes on reliably, it shouldn't be key switches, wires or any other voo-doo, the ECU, ignition cylinder or any wiring shouldn't be suspect.

Just as reliably, when that p0431 code is pending/present, that CEL fails to light with that key on, engine off.

Is there something in the OBD2 that I'm missing that would cause a change in the CEL light with the key on, engine off?
 
1 - 4 of 4 Posts
Top