Jeep Wrangler Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter #1
i found a guy in IL. with a nice looking 05 willys edition.
6 speed, looks pretty much stock .
but he said he has new exhaust from the manafold back, cats and all. back rotors and brakes. it only has 57,ooo on it. and is the 3rd owner.
i would of thought with that low of milage it would have been a one owner.
it has 3.73 gears with 31's on it and gets 17 to 20 mpg, that sounds awful good from what i been reading on here...LOL
i didnt like it when i first seen it but its growing on me , i kinda want it now.
he says he has never had it off road. but he is the 3rd owner.
any thing i should be suspisous of ? or check out if i go look at it?

Thanks
 

·
Registered
Joined
·
136 Posts
If its a good price hop on it. I love that edition. My dad told me a cool saying when looking at a used vehicle. B.e.l.t.s. brakes exaust lights tires and seats. If those are good buy it. Check oil. diff fluid if he'll let ya. Undercarrige(it probably has rust but look for holes). every thing is dry motor tranny axels brakes and radiator.
 

·
Registered
Joined
·
941 Posts
Willys edition is great. As for the gas mileage well I don't know. I have 3.73 gearing with 32" and I get around 12.
 

·
Registered
Joined
·
1,180 Posts
An 05 with under 60K under normal use should have a perfectly good factory exhaust.
A PO may have put on some sort of "performance exhaust" system, only to be replaced after he or the next PO found it to be unsatisfactory.

Post pics when you get the rig home... :)
 

·
Registered
Joined
·
2,048 Posts
I sold my 04 Rubicon last year with 52,000 miles on it and I was the fourth owner. Jeeps are toys for many people thus they are frequently sold to finance other hobby type activities.
 

·
Registered
Joined
·
31 Posts
i didnt like it when i first seen it but its growing on me , i kinda want it now.
When I was looking at my '05 Willy's Edition it did not grow on me till 4 weeks later. The only thing I still do not like are the blingy tube bumpers, they have to go on mine sooner rather than later. The all green (including top) is pretty cool.
 

·
Registered
Joined
·
72 Posts
Discussion Starter #7
An 05 with under 60K under normal use should have a perfectly good factory exhaust.
A PO may have put on some sort of "performance exhaust" system, only to be replaced after he or the next PO found it to be unsatisfactory.

Post pics when you get the rig home... :)
kinda what i thought also.
and good point on the after market
i will ask him why he had too do that.
Thanks gang.
 

·
Registered
Joined
·
127 Posts
i have an 05 willys edition that gets around 16-18 mpg. couldnt understand why everyone was getting around 12-14 when i read up on it. i'm running 31's with no lift which helps tremendously im sure. mine is also a 6 speed and just hit 74k miles. i'm the 2nd owner. wheres it located in IL?
 

·
Registered
Joined
·
941 Posts
cory05tj said:
i have an 05 willys edition that gets around 16-18 mpg. couldnt understand why everyone was getting around 12-14 when i read up on it. i'm running 31's with no lift which helps tremendously im sure. mine is also a 6 speed and just hit 74k miles. i'm the 2nd owner. wheres it located in IL?
Yes many things make a difference to the gas mileage. Lift thould not make too much of a difference but thw BFG tyres that I am running is heavy as hell.
 

·
Registered
Joined
·
1,489 Posts
cory05tj said:
i have an 05 willys edition that gets around 16-18 mpg. couldnt understand why everyone was getting around 12-14 when i read up on it. i'm running 31's with no lift which helps tremendously im sure. mine is also a 6 speed and just hit 74k miles. i'm the 2nd owner. wheres it located in IL?
With my 3spd ill only get 16-17 at best on the highway. Overdrive makes all the difference.
 

·
Registered
Joined
·
72 Posts
Discussion Starter #12
ok i ask him about the exhast.
he said it threw a code . he took it the a dealer. they told him one of the cats was bad so he had the whole system replaced.

which i think i have read on here ,that it is a issue on some of them.
and it was front rotors, not rear...lol
 
1 - 13 of 13 Posts
Top