Jeep Wrangler Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Recently had to replace the radiator fan due to the old one burning out. After installing the new fan, we started experiencing the concerning issue above. Usually after letting it sit all night, when I try to start it in the morning, everything normal comes on except the jeep won't crank/solenoid won't click. We have been able to remedy this initial no-start by unplugging/replugging relays in TIPM, or simply just pressing/wiggling TIPM around. Even then, we can get it to start, but after a few seconds the engine will cut out and die, with everything else electrical running, including the fan (with AC on). I also have had the engine cut out on me while driving, which is particularly worrisome.

Not much of electrician myself, so my Dad has been doing all the playing with/electrical install of the fan, so im not 100% sure what all he has messed with, tried, etc. Im just wondering if anyone has any suggestions I could try.

Additionally, the following error codes we have received when getting the car to start after one of these episodes is a p0430 (related to the control of electric fan), as well as some lost communication codes for the TCM (U0110B and U0100 iirc).

Just hoping its not the TIPM itself, but im afraid if I take it to the dealership they will immediately call it a TIPM issue, because its a 1200$ repair. Just got done replacing a 660$ radiator fan... I don't know if my wallet can take it.

Jeep has 95,000 miles on it also.
 

·
Registered
Joined
·
504 Posts
TIPM`s can be rebuilt for around 275.00 from several deifferent vendors on ebay. Usually a 7 day turnaround with a 1 year waranty.
 

·
Premium Member
Joined
·
1,245 Posts
before you start spending money. check the ground connection and power connection on the battery real good. it might be loose and not seem loose when trying to wiggle it.
 
1 - 5 of 5 Posts
Top