Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
For a while now I have had acceleration problems with my YJ. If I am gentle on the gas it seems to be ok with a miss/surge while accelerating. However, when I push the gas to the floor you can hear the engine stumble/hesitate/sputter/bog. It will accelerate while its sputtering but just very slowly. I've noticed that if I'm at the right RPMs and then I give it full acceleration it will catch and you can see what the engine is supposed to do but most of the time, if it catches at all, it will Jerk around go from proper movement to the sputter.I plan on adding a video later tonight so you guys can actually hear the problem, but until then any input would be much appreciated. Thank you in advance and did I mention I've been to 3 different mechanics all of which couldn't figure it out or gave me false diagnostics. Note I do the work myself. Thanks again!

Mods that may effect the engine:
2" Suspension & 2" Body Lift
33x12.50 BFG All Terrains
Re geared 4.56
Sadly a 4 banger

What I have replaced so far:

Rebuilt Automatic Transmission (Had it checked again)
Fuel Pump
Fuel Filter
Cleaned Throttle Body
Throttle Position Sensor
Fuel Pressure Regulator
Cat-back exhaust system
Spark plugs & wires
Distributor cap
Rotor
Air Filter
O2 Sensor
Valve Cover Gasket
 

·
Registered
Joined
·
65 Posts
Honestly there's only three things i can think of that you don't have listed. The cps, a camshaft sensor, and vacuum leak.
 

·
Premium Member
Joined
·
10,093 Posts
Check your timing at idle should be 8 DBTDC and then check that it advances quickly when you move the throttle. It really sounds like a timing issue but the ECU controls that from inputs like CPS, can sensor TOS WO switch
 
1 - 7 of 7 Posts
Top