Jeep Wrangler Forum banner

1 - 20 of 140 Posts

·
Registered
Joined
·
22,156 Posts
Discussion Starter #1
So I picked up this 1981 CJ5, I think its in pretty decent shape. The body has rust here and there. The frame seems good. The motor is a 258, believe the trans to be the T176, and a D300 for a t-case. Dana 30 front and AMC 20 rear. Have no idea what gears are in it, still need to find that out. The 258 knocks i'm told, I haven't tried to start it and listen to it. I believe barrie lol. Plans right now are to get it running, fix the suspension issues, make the brakes stop and do a fluid fest on it. Then drive it around the street, and slowly make it "shine"

So here's some pictures of it at barrie's getting loaded up and ready to head north..




Oh and here's where it sat for awhile..


Here's it arriving at my place, dang indiana had to drop some snow on us.. this is the last time it will see snow..


getting it unstrapped from the dolly

unloaded and warming up in the garage next to the red jeep

It came with some factory wheels that will go back on it
 

·
Registered
Joined
·
22,156 Posts
Discussion Starter #3
the dana 30, see its currently sprung over, I wanna get new stock springs and shocks, and put it back to spring under..Also take the crazy big shackles off of it and put stock ones back on..


Amc 20..

the bed area


I had my pug check for rodents


Playing around with the fold down windshield.. lol


the front drivers seat looked to be out of an f150 and its cloth. it was all moldy and stinking up the garage, so out it came! however I had to cut it out because the nut in the tub was just spinning..

yucky seat..


thats pretty much it, I drained the oil in the motor, it seemed decent. I was gonna pull the oil pan and peak around but haven't yet. I pulled two of the spark plugs and they seemed in really good shape. So I'm hoping the motor is still in somewhat decent shape for the rebuild. This is gonna be a slow thread of fixing it up, so you may get bored!
 

·
Registered
Joined
·
22,156 Posts
Discussion Starter #14
Only thing I have really picked up for it is a new set of shift knobs.. boring I know lol


I charged the battery up, well the most it would hold a charge, turned on the lights and not all work.. will have to look into it, electrical is not my strong point

noticed the radiator was dry and started filling it up, found out the heater box leaks..

While messing around under it, I noticed someone removed the trans mount bolts..

I found one in the back of the tub that seem to fit.. need to find another one.. but at least it makes everything more solid for the time being..

and is this supposed to be open like this?

Was doing some searching into the factory paint color.. gonna go with dark brown..(the photo kinda makes it look maroon but its really brown)

and I finally got around rolling it out and getting it soaped up and hosed off..my son helped move it out..

and my wife had WAY to much fun helping push it back in the garage..

and last but not least.. seems like a happy driveway/ garage right? lol
 

·
Registered
Joined
·
22,156 Posts
Discussion Starter #16
Well did a oil change on the motor, just because I didn't know what was in it and I'm guessing it was old. The plan was to try and get it to start. Also picked up some primer and paint for when I pull the front axle to redo the suspension on it and bring it back to spring under.
So charged up the battery...and nothing. Starter just makes a slight grinding noise.. I feared the motor was stuck/ locked up. I removed the fan belt and was able to turn the motor over by hand fairly easily. So now back to figuring out how to get it to fire.

Which it got late and I just fiddled with other stuff..

but I did get the rear lights working.. So it wasn't a total fail

The next day the cops came. and checked it out.. and deemed it safe to sit in my garage!
 
1 - 20 of 140 Posts
Top