Jeep Wrangler Forum banner

Keyfob / Key Issue

782 Views 3 Replies 4 Participants Last post by  Jessejeeptj
A few days I plastidip'd my keyfob, having removed all the internal parts prior of course. Everything worked fine. Then I got a little carried away, but don't ask how, but the bottom part of the circuit board got a little chewed up, but not bad. The inside of the plastic where the key is embedded in the plastic is a little chewed up too. Still worked! Today I went to start my Jeep and it turns on, and 3 seconds later, turns off. The red light above the temp gauge stays on. I reset the IOD fuse and removed the negative battery terminal and reset everything, but the same issue. The remote works fine. All the buttons; lock, unlock, remote start and panic all work. But it's like the key isn't being recognized as a valid key. Even when I use the remote start, the moment I put the key in, it turns off. Any ideas? I thought at first it was the control module going bad but its a little coincidental that all this is happening around the same time I had it apart and messing with it.
1 - 4 of 4 Posts
If it's the little round led then it's your security light. The ecm is picking up an unsecured issue with the jeep and shutting it down. Check your hood pin switch if you have one.

The remote start won't operate properly until the problem is found and cleared.
Well, sounds like you broke/lost/interfered with the RFID chip. Since I have never taken a keyfob with remote controls apart, I don't really know for sure, but I have taken a plain old key apart and saw that there is a RFID chip about the size of a grain of rice embedded in the plastic. If you damaged it, or lost it, you are probably out of luck and would need to purchase a new keyfob remote.
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.