Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 9 of 9 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
I have developed a problem with my 90 YJ. When I turn left sharply at speed the engine dies. Then it coasts for a bit and the engine refires and runs normally. The only thing I can see is that a small hose running from what appears to be a small filter connected to a wire on the left side of the engine near the starter is not connected to anything and I cannot find where it connects. Please help. (Left side facing rear).
 

·
Registered
Joined
·
132 Posts
Crankshaft position sensor?
 

·
Registered
Joined
·
339 Posts
How much fuel do you have in your tank when it happens. Mine does this when I'm low on fuel, never an issue with a full tank for me. I haven't dropped my tank yet to find the issue. Just an idea.
 

·
Registered
Joined
·
2,867 Posts
How much fuel do you have in your tank when it happens. Mine does this when I'm low on fuel, never an issue with a full tank for me. I haven't dropped my tank yet to find the issue. Just an idea.
^ yup this is the most annoying thing on my '90
 

·
Registered
Joined
·
212 Posts
Yep, if your low on gas, when you turn left at a decent speed it'll stall. Just keep gas in the tank and I bet you'll be fine
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #8 ·
Thanks to everyone who said put gas in it. Filled the tank and problem went away. Found the tube went to the 4 wheel drive sensor.
 

·
Registered
Joined
·
28 Posts
hey i have an 89 2.5l that does the same due to being a ff and work long distance does any one know how to fix that issue it is a new tank before i bought it any info on this would help
 
1 - 9 of 9 Posts
Top