Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 1998 Jeep Wrangler, and something is amiss...but alas, I don't know the moving parts of a marble.

It was serviced this morning, and within an hour, it wasn't running right. The shop is closed, so it will be Monday before I can take it back. Until then, I'm seeking help on a possible diagnosis.

It is very sluggish and top speed is 35-40mph. It occasionally acts as if it is losing power and slows down, and when that happens, the Jeep pulls harshly to the right. This will pass after a brief couple of seconds and it then it drives straight with no pull, and you can accelerate back to 35-40mph...but no higher. The "check gauge" light pops on and then goes off (it has done this 3-4 times). There is a hot smell that I've not noticed before, but the temp gauge is showing normal. Just prior to all of this starting, I was driving around 55mph, and then it started to shake on the front end (never happened before), which led me to pull over. After that, I started back to the shop, and the symptoms described above ensued. Prior to servicing, it was running literally with no issues. I'm wondering if a vacuum hose or something simple could have been dislodged that would create similar symptoms. I'm just lost, and I hate worrying about it until Monday. Hoping it could be something simple, but I'm fearing it could be a major problem.
 

·
Registered
Joined
·
281 Posts
the first issue may be a cat converter issue not sure though but i had the same problem with my old truck it was just starting to get worse and i had the cel light and i had to have my foot to the floor to keep it at 65 to 70 and i barely was able to. The shaking issue could be related but not sure. It all depends on what you had done at the shop. if was a sensor i would think the cel would be on constant. Also is the check engine light flashing if that is happening it is seriously misfiring and i would not drive it. I would have to say that the shop did something or neglected to hook something back up if it was running fine before or it could be a coincedence that the cat decided to kick the bucket like me I spent a thousand dollars on getting the intake manifold gasket replaced along with radiator and some misc stuff and then 2 weeks later my cat converter crapped out on me
 
1 - 2 of 2 Posts
Top