Jeep Wrangler Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
683 Posts
Discussion Starter #1
On this 07 Ruby I’m trying to sort out a few details.
One of which is, what I consider, extended cranking prior to starting.
I have to hold the key in the cranking position for approximately 3-4secs before it starts.
It idles & runs fine, no sputtering, missing, stalling etc. Furel pump sounds solid & spools up normally for a couple seconds each time I turn the key on. I’ve tried leaving the key on for 5-10secs before cranking, but no change.
Is this normal? I expect to basically just bump the key to start. But maybe I’m wrong?
Any help/info is appreciated.
 

·
Registered
Joined
·
363 Posts
On this 07 Ruby I’m trying to sort out a few details.
One of which is, what I consider, extended cranking prior to starting.
I have to hold the key in the cranking position for approximately 3-4secs before it starts.
It idles & runs fine, no sputtering, missing, stalling etc. Furel pump sounds solid & spools up normally for a couple seconds each time I turn the key on. I’ve tried leaving the key on for 5-10secs before cranking, but no change.
Is this normal? I expect to basically just bump the key to start. But maybe I’m wrong?
Any help/info is appreciated.
Cycle dance the ignition on/off a half dozen times each time leaving the key on for 5-10 seconds. Could be the check valve.
 

·
Registered
Joined
·
683 Posts
Discussion Starter #3 (Edited)
I tried that just now, but no change.
But one thing I noticed is, it smells like raw fuel coming from the exhaust after performing the key cycling above^ & starting it.
So I’m wondering if my injector or injectors are leaking, bleeding off pressure?
 
1 - 3 of 3 Posts
Top