Jeep Wrangler Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hey guys,

This is my first jeep and I'm new to the site though I posted a couple times yesterday.

Anyways, since getting my jeep I've noticed the fender flares on both sides on the front are loose at the back (beside the doors), I can wiggle them quite a bit and I notice them on the highway (no noise but I can visually seem them vibrating). I'm worried they will come off on the highway or in the car wash.



You can see in the image there's 2 screws poking through but they go into nothing. I mentioned it when I was at the dealer and they took a look at 3 other jeeps they have for sale and they said it was the same on all of them. Just curious if this is normal? Do I need to buy some clips to fix this?

Any help is appreciated! Thanks!
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3


Can anyone check their jeeps to see how this is supposed to be? You can see there's 3 screws in the red circles but they don't go into anything at all. Is there supposed to be something in that cavity where the middle circle is?

I asked the dealer last time I was in for a recall and they checked the 2014's they had in the lot and they were all loose. It flaps in the wind on the highway and both front sides are the exact sam and Im just concerned about something getting ripped off.
 

·
The Bad Guy
Joined
·
23,119 Posts
I need another picture pulled back for perspective. If the flare is loose it could be a loose or broken clip. That's all that holds them on. Those screws look like they may be the liner but can't tell unless you pull back the camera for a full shot as well.
 
1 - 4 of 4 Posts
Top