Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I have an 07 jk on a 3in suspension lift and 33's on it. I am having a loud knocking coming from what seems like the middle of the jeep. The problem is happening slowly as I start to accelerate and just continues to get worse as I get faster. I have a tom woods shaft and just put new U joints on it so not that. I have new upper and lower ball joints and steering. I am at my wits end on what it could be. I don't feel particularly safe driving it but need to figure out what the problem is. I have searched all of the threads and it mostly seems to be the U joints but not mine. any help is greatly greatly appreciated. thanks guys.
 

·
Super Moderator
Joined
·
53,784 Posts
I have an 07 jk on a 3in suspension lift and 33's on it. I am having a loud knocking coming from what seems like the middle of the jeep. The problem is happening slowly as I start to accelerate and just continues to get worse as I get faster. I have a tom woods shaft and just put new U joints on it so not that. I have new upper and lower ball joints and steering. I am at my wits end on what it could be. I don't feel particularly safe driving it but need to figure out what the problem is. I have searched all of the threads and it mostly seems to be the U joints but not mine. any help is greatly greatly appreciated. thanks guys.
You're assuming the new joints/DS is ok. Did you check for any play in the diff or TC end ?
Is it the front shaft ? Are you running adjustable control arms ? Do you know what the pinion angle is ?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
I am assuming that yeah. I checked for play in both the front and rear shafts. Everything seems status quo, no unusual play or grease flings. With all 4 wheels off the ground I still get the noise in 2wd and 4wd. I am running adjustable control arms and I will be honest I'm not sure what the pinion angle is.
 

·
Super Moderator
Joined
·
53,784 Posts
I am assuming that yeah. I checked for play in both the front and rear shafts. Everything seems status quo, no unusual play or grease flings. With all 4 wheels off the ground I still get the noise in 2wd and 4wd. I am running adjustable control arms and I will be honest I'm not sure what the pinion angle is.
How about caster ?

Did you check the axle u-joints?
D30 up front ?
 
1 - 4 of 4 Posts
Top