Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
ok so I get a loud knocking of metal on metal every time I hit a bump at slow speed. I know all the bushings should be replaced on my 93 yj but when I checked the tranny mount there is no play however on the driver side motor mount I can fit a small screwdriver in between the rubber and the metal bracket on top, is that normal? im wondering if I should replace the mounts to fix the issue but not sure if that is the right amount any help?
 

·
Registered
Joined
·
1,610 Posts
If its only between the top of the rubber and the bottom of the metal arch its fine. Thats how mine are and I just messdd with mine and out a MML on and they were like that. I eould look at your exhaust. Mine was rattling during take off and the mounts and bushings were bad. Hope this helps.
 

·
Registered
Joined
·
1,157 Posts
Try the front track bar if you don't know where it is watch the beginning of this video https://www.youtube.com/watch?v=9uQwlmlhiF4

he explains the whole front end. If your track bar is still there (alot of yj's have them removed) try pushing up and down on it pretty hard to see if it shifts. If it is gone or not moving then how about shocks? I have a bad clunk right now when hitting bumps while turning. And I know for a fact it is my shocks.
 

·
Registered
Joined
·
1,157 Posts
um that was some interesting formating??
 
1 - 4 of 4 Posts
Top