Jeep Wrangler Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
647 Posts
Discussion Starter #1
So santa brought me the lift and i put it on two days ago so here's my go on it


Instructions: 10 out of 10 awesome and easy to follow

Quality: 8 out of 10 all the pieces were built with high quality parts but one dust boot was ripped thankfully we had one that fit well but over all it was no big deal

Fitment: 5 out of 10: Everything in the rear went in awesome and perfectly then when we went to the front there was a whole new set of problems that included a BFH, air chisel, and some grinding, the shock extensions in the front did not line up whatsoever with the stock bolt holes. we made it work but its deffinitaly something I'm going to tell AEV about.

Ride: 10 out of 10 cant even tell its there besides being a little bit higher

Happiness: 8 out of 10 the only reason it's not a 10 is because of the fitment issues you can definitely notice the increased ride height and the jeep looks much better :dance:
 

Attachments

·
Registered
Joined
·
647 Posts
Discussion Starter #2

Attachments

·
Registered
Joined
·
189 Posts
Installed one in my sons 2dr, but ditched the stock shocks and the provided extensions and put in a set of Bilsteins for 2" lift in their place. Resulted in a VERY good ride.
 

·
Premium Member
Joined
·
12,478 Posts
Kinda surprised about the fitment issue. AEV's usually right on, from what I've heard.

Your Jeep looks great, though. No excuse now for not going into hock over some new tires. :D
 

·
Registered
Joined
·
1,643 Posts
looks great ;] and no rake as i can tell from the pics..perfectly level ;]
 

·
Registered
Joined
·
973 Posts
What year did you have? Maybe something changed in the 2012?
Hi, I have a 2011/ maybe something did change for 2012??? Everything was perfect bolt on with mine. I just wish I had ordered new shocks, I will be changing them after winter out here so I can remove the shock brackets that came with the kit.
 

·
Registered
Joined
·
647 Posts
Discussion Starter #15
It may be just the 2012s that have the fitment issues I haven't had a chance to call aev yet but I more than likely will on Tuesday hopefully they can give me some sort of answer and if they haven't yet try it on one of their new jeeps
 
1 - 15 of 15 Posts
Top