Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 3 of 3 Posts

·
Registered
Joined
·
442 Posts
Discussion Starter · #1 ·
So just did all 4,balljoints and drivers side wheel bearing and all was well fir a couple of days and now I have a weird whine noise that stops once the jeep is below 15mph. The only thing I can cv ompare it too is similar to someone rubbing their shoe on a bike tire at speed. On top of that I still have a slight creek/ popping noise when making right turns :/

Anyone have any thoughts? Ill post a video in a few.


I'm seriously considering trading her in on an lj or a Rubicon. Or, taking out another loan and doing an 8.8 high pinion 30 swap and getting 33s while I'm at it...what would you guys do?
 

·
Registered
Joined
·
1,033 Posts
you don't need a new axle for 33's, save your money and just run the dana 35 till you have enough to do an axle swap without taking out a loan. As for the ball joints before I replaced mine they were squealing badly on turns that's how I knew they were bad. I don't know what your sound is exactly though sorry. Maybe you installed it wrong? or you just got a bad one?? check for a loose fit. did you accidentally flip the ball joints, one type goes in the top and one goes in the bottom, I believe they are two different types. Did you grease it after the installation? Sorry I'm not much help I did it a while ago just trying to remember the things we went through. I do recall the shop gave us one incorrect ball joint! and BUMP :)
 

·
Registered
Joined
·
442 Posts
Discussion Starter · #3 ·
Well the problem isn't the balljoints I know that. I'm an automotive student so I would hope I could get that right lol. Seems I have another issue now
 
1 - 3 of 3 Posts
Top