Jeep Wrangler Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
My friend left her Jeep with another friend this weekend. I don't think anything bad happened to it, but it won't start.

The battery was replaced.
I cleaned the terminals.
The PDC has 14v, the Starter has 12v when the ignition is turned.
All lights and gauges work so probably not a CPS.
Fuel pump primes.
Engine ground looked clean so I didn't remove it.
Fuses looked intact.
Horn relay swapped with fuel pump relay, horn worked.

I really don't think it's the starter and I doubt it's the CPS. Some fresh ideas would really help, thanks.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #2
After some extensive reading I'm starting to think it is the CPS after all. Is there a way to test this on an '04 Unlimited? All I can find is how to test 87-95 and 97-01. On the newer Jeeps it says I should get infinite continuity between pins B/C. I'm not sure how this works when the plug is not plugged into anything though. Anyone have any experience with this?
 

·
Registered
Joined
·
1,141 Posts
MojoHand said:
After some extensive reading I'm starting to think it is the CPS after all. Is there a way to test this on an '04 Unlimited? All I can find is how to test 87-95 and 97-01. On the newer Jeeps it says I should get infinite continuity between pins B/C. I'm not sure how this works when the plug is not plugged into anything though. Anyone have any experience with this?
Mine had that same problem also. Although I don't know what went on because the people I had tow it they fixed it. I didn't have time. It was my primary vehicle. But that's what was wrong. It would turn and turn and turn but no start.
 

·
Knows a couple things...
Joined
·
49,125 Posts
Try cycling the ignition on 3-4 times, keeping it on each time long enough for the fuel pump to shut off. Then try starting it and see what happens.

If that doesn't help, try unplugging & reseating the connector for the crankshaft posistion sensor. Its connector is low on the firewall.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #5
Ok,

Cycled ignition
Changed Crankshaft Position Sensor
Reattached Ground to motor
Swapped ASD relay

None of this worked. The starter turns over, I can hear it. Everything was supposedly running fine before the battery died so I have no inclination to think it is anything other than electrical.
 

·
Registered
Joined
·
8 Posts
Jerry, I am having a problem with my 06 Wrangler. Do you think this could help with my problem?
My Jeep starts when it wants. It will not even turn over at all. It will not start for several hours. Then it will start and run fine for a few days, then the same thing happens. Sometimes it starts after a few minutes and sometimes I have to let it sit over night. It will not turn over at all. The shop cannot figure out what it is because it will start everytime I bring it in. Any ideas. This Jeep is driving me crazy! Need help please.
 

·
Knows a couple things...
Joined
·
49,125 Posts
Meaux_123, have you removed both battery connections and used a wire battery brush to clean the posts and inside of the connectors? Are the connectors tight enough on the battery posts that you can't wiggle or move them with your hands?
 

·
Registered
Joined
·
20 Posts
Discussion Starter #12
Meaux, you probably have a bad ground. Does this ever happen after it rains? Do you have power to everything else or does the whole Jeep die?
 

·
Knows a couple things...
Joined
·
49,125 Posts
Jerry, it is an automatic.
MojoHand, it does not have a security system. I can hear the relay click when i try to start it.
Next time it won't start, try moving the shifter between Park and Neutral while holding the ignition in the Start position. If it starts when you move the shifter between Park & Neutral, your shift cable length is out of adjustment.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #14
I don't think there's a security system. I just opened it with a key. I'm thinking TPS, or a fuel sensor gone bad from the new battery jolt?

As for the Auto Shut Down relay, I swapped it with another one and nothing happened.
 

·
Registered
Joined
·
8 Posts
It happens mostly during the winter. It is not necessarily when it rains. Of course the winter thing may just be coincidence. It is not starting right now. I just tried shifting it while holding ignition in start position. This did not work.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #17
The jeep is no longer in my possession this evening, I did try to move the shifter around while starting it. I even tried to start in neutral and it did the same thing. Just cranks and cranks and cranks. If I turn the key really quickly I can even feel the starter catch for half a second.
 

·
Knows a couple things...
Joined
·
49,125 Posts
Oh whoops I had momentarily forgotten it was cranking... forget my suggestion to try moving the shifter.
 

·
Registered
Joined
·
8 Posts
No, not cranking now. The only sound is the relay click when i turn the key. This problem started after I took the center console apart last year and pulled the carpets to clean it. Since then i have this problem occasionally.
 

·
Registered
Joined
·
8 Posts
There was something called a power plug that was wired in under the dash. I just cut this out and reconnected the wire it was wired into. I though maybe this had a bad connection, but that didn't work.
 
1 - 20 of 23 Posts
Top