Jeep Wrangler Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I apologize if this has already been done. I haven’t found anyone with this issue after swapping in an engine. I’m a long time lurker (this forum has helped me change everything from head gaskets to oil pumps) and have read everything I can find on the topic, but I am at a complete loss.

I had to replace the engine on my 2017 JK. At 66K miles everything started going wrong and was out of warranty. I had done a lot of work and overhaul prior to the engine swap to keep it on the road.

I found a 3.6L out of a Ram 1500 with only 40K miles (the guy I got it from rebuilds cars and drag races, so he pulled this one to do a Hemi swap). Overall the install was easy. It was a direct swap. Everything fit like it should. I swapped my timing cover, accessories, oil pump, oil pan, CPS sensors, coil packs, and spark plugs into the new engine (some at time of swap and some during trouble shooting). I also changed the pilot bearing and throw out bearing while I was in there and had easy access.

After the install, I went to start it up and it cranked but wouldn’t turn over. I could smell gas, and it seemed like it had flooded. I checked for pressure on the fuel rail and definitely had that. I let it sit for a day to dry out out and then tried again. The line connecting to the fuel rail popped off. Apparently I just didn’t have it fully connected after testing pressure on the system. Tried again and same situation. It sounds like it’s trying to turn over but just doesn’t.

I unhooked one of the coil packs and plugged in a spare with the spark plug attached. Then I cranked to see if there was any spark. It was probably 20-30 seconds before there was any spark. I swapped out the coil packs and spark plugs with the ones from my Jeep (the spark plugs are maybe a month old with a couple hundred miles). The ones I pulled were definitely fouled up. After changing this out and rechecking all of the wiring and sensors I could find, I tried starting again. Same problem except no spark at all now. The one spark I had before swapping seemed to have been a fluke.

I replaced the CPS sensors with the ones from my Jeep (they had been replaced not too long ago due to other issues, so I know they’re working). I also pulled the ground straps to see if maybe one of them wasn’t making a good connection. Still won’t turn over

I checked all of the fuses. Found one 20amp fuse for the power outlet blown. No idea how long it’s been blown, but I used to take the Jeep camping and plug stuff in so it could have been like that a while. Replaced the fuse. No change. I pulled the IOD fuses after reading another thread. I checked to make sure it wasn’t the security system (also found on another thread). I unplugged the fuse box and plugged everything back in to make sure I hadn’t mixed up a harness underneath. No change.

I tried starting in 4L to see if I had somehow tripped a neutral safety switch. The transmission definitely engages and moves the Jeep forward when I try to crank but doesn’t start.

I put the battery on a charger this morning because all of the cranking and not starting had started to dim my dome lights when I cranked. The battery was replaced at the beginning of the year. Right at 60K.

I’m chasing possible electrical issues, but my Jeep fired like it was supposed to a couple weeks prior to pulling the engine. The tech at the stealership let me stand there while he did all of the diagnostics and told me I needed a new engine, which I had been trying to avoid. I never had an electrical issue prior to this.

The only thing I haven’t changed is the fuel rail and the wiring harness that came with it, but it looks like the only thing that controls is the fuel rail. And judging by how much fuel was on the spark plugs I pulled, this part is definitely working. On a previous excursion I replaced the head and started the Jeep with this completely unhooked and it still started right up. So I don’t think that is the problem.

I don’t have any codes that come up with turning the key 3 times and no access to a scan tool to be able to see what is happening while I crank on it.

I did notice that after trying to crank but not turning over that I also have a faint almost honking sound. Kind of like my horn honks twice but you can barely hear it. I have read on other threads that this may be a computer issue? I don’t fully understand how to go about testing this though or what would have caused it to fail.

I think I’m missing something really simple and stupid, but I don’t know what it is. Any help would be appreciated!
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Update: I replace the crank position sensor again with no luck. So I added a can of STP to the fuel, and moved it outside.

To keep it running I had to keep giving it gas, so I sat on the gas pedal long enough to finally throw a code: P0303 misfire cylinder #3

I started by pulling that spark plug out, leaving it in the coil pack, and cranking over the engine. I had spark and it was at this time the Jeep just stayed idling on its own. It had a really rough idle.

Next I did a compression test on this cylinder and it came back at 0 psi. Not even a blip. So I tried a leak down test and it would only hold 10 psi so I scrapped that idea. I added a little oil in the tube and repeated the compression test. Still 0 psi. I know my gauge is working because I had used it on the previous engine a few weeks ago to diagnose a blown head gasket.

I took the cap off the radiator to watch for bubbles and didn’t get anything. So that was a plus at least.

At this point I was thinking I have a valve stuck open that wasn’t letting the cylinder build compression.

I took the Jeep on a test drive and definitely had a vacuum-like leak from around the PCV valve (new PCV valve but looked like it had gone bad and leaked) and some blow-by into the plenum, but the code was gone and the Jeep ran smoother the more I ran it. It burned a little bit of oil through the plenum from what I was smelling but then stopped.

So I figured maybe that valve would work it’s way loose. I also had a ticking sound like a lifter, so I’m thinking that was the exhaust valve stuck up was tapping against the cam?

I drove it again tonight (day after I got it to stay idling) and overall ran pretty good. Then about 45 minutes in the Jeep had a mind of its own. It starting shaking, the rpms we’re stuck at about 2200 without giving it any gas. I thought it was the end. After about 30-60 seconds, it straightened out and drove smooth as could be. No codes through any of this.

I pulled off at a gas station up the road to check everything out. The oil level was good and the blow-by seemed to have stopped. I couldn’t hear a vacuum leak anymore either.

I drove another hour after this and the Jeep ran like a dream.

I won’t be able to do another compression test for a few days, but could this have been just an exhaust valve that was stuck and worked it’s way loose? I’m not sure how long the engine sat before I bought it, so maybe it just had some build up that needed worked out and I have miraculously avoided a tear down?
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top