Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 13 of 13 Posts

·
Registered
Joined
·
218 Posts
Discussion Starter · #1 ·
Picked up a 95 YJ over the weekend, body and frame are in excellent shape, has a 350 in it (still trying to figure out from what), TH350 auto, Dana 30 & 35 with 410/411's according to the tags. Bikini, soft top, half doors and taller seats all like new. MT Classics with (pretend :happyyes:) bead locks and 33" Nitto Terra Grapplers.

First projects will be to fix the hot starting issue with the Edelbrock (usually a heat spacer will fix it), replace some gaskets to stop the oil leaks and figure out what all the extra poorly run wiring is for/from. Dash lights don't work, Hella spots are mounted but not connected to anything etc.

But my first issue is figuring out what this is? It looks like a receiver of some type that runs down to the box on the tranny that is connected to the shift linkage. any ideas?
 

Attachments

·
Registered
Joined
·
158 Posts
Digital shift indicator would be my guess...
 

·
Registered
Joined
·
218 Posts
Discussion Starter · #3 ·
Well I'll be...thats what it looks like. I'm not real sure of the purpose of it, but if all it's supposed to do is tell me what gear I'm in, I'm. Going to pull it out. I don't think it works.
 

·
Registered
Joined
·
218 Posts
Discussion Starter · #4 ·
Thanks for the help Jak_Rak, since the last one was so easy, try this one. It looks factory to me, I can't trace it very far back without taking the dash apart, but is wrapped in foam insulation and runs above the heater ducts. In the picture, the black wire is disconnected, and on the right end is a momentary button (meaning it doesn't lock into place). Only two wires that I can find...
 

Attachments

·
Registered
Joined
·
158 Posts
I think that was attached to the heater control. It's actually a vacuum switch.
Yes, it's attached to the HVAC controls, and is activated by the topmost lever on the panel (OFF, DEF, HEAT, VENT). In the OFF and VENT positions, the switch is depressed, in the DEF or HEAT positions it is open. I'm pretty sure it kicks the fan on in low (fan switch at the bottom setting) when in DEF or HEAT modes.

 

·
Registered
Joined
·
897 Posts

·
Registered
Joined
·
218 Posts
Discussion Starter · #10 ·
Sweet, got the controls all fixed and they work great! Even got the dash lights fixed while I was in there.
 

·
Registered
Joined
·
10 Posts
What did you find with the dash lights? I have the same problem with no luck. Checked nearly everything and no luck.
 

·
Registered
Joined
·
218 Posts
Discussion Starter · #13 ·
It has a short somewhere, never did find it, but they are back to working...again.
 
1 - 13 of 13 Posts
Top