Jeep Wrangler Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
So I picked up a 6cyl YJ this weekend, first jeep :wavey: , it had the Maintenance required light on and the guy said it was throwing the code for a long time and he never worried about it. I checked it last night and it is throwing code: 31: EVAP solenoid or circuit. And code 33: Air conditioning clutch relay.

I have been trying to look up what 31 means for a while and what 'problems' would be associated with it and haven't had any luck so I am attempting to figure it out here, along with how I go about fixing it..

For the 33code, I don't think this has an A/C so not sure why it would be throwing that.

Also I have noticed that after driving for a little while, when I come to a light or a stop and am slowing down if I take it out of gear and let it coast to the stop the RPM's will drop below 500 and sometimes stall out or go so low and it catches itself and keeps running.. A quick stupid fix I did is when I let it out of gear give it a touch of gas and it will stay running. Not sure what exactly is causing this but I need to figure it out, so it stops dying..

Also The 4x4 indicator light is on, and I saw the sticky thread up at the top but it seems all of the pictures are gone, but I am going to try and fix that this weekend using that thread as well..


Sorry for the wall of text and all the problems, just trying to get the rig fixed with the issues before I tackle other issues and take her out 4wheelin.

Thanks in advance :)


And here is the rig:
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
I had someone mention to me that it might be a plugged cat? I hadn't thought of that yet.

I will take a look at that site patrick and see if anything stands out, thanks!
 

·
after birthday glow
Joined
·
1,963 Posts
ok first off was the jeep carberated or was it newer then that if its got a carb just try and do a tune up like plugs cap fuel filter and clean the carb out next as far as the four wheel drive light i just fixed mine if u have a 90 or later its all vacuum so check the vacuum hoses for leaks the actuator is on the passenger side of the front axle if the line is broke witch normally happens then the light will stay on if it a 91 and newer then theirs a sensor that may be bad or ur stuck in 4x4 if the front actuater is good then theirs a switch on the top of the transfer case that is probly the culpret hope i helped
 

·
Registered
Joined
·
2,207 Posts
here is a code list
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
ok first off was the jeep carberated or was it newer then that if its got a carb just try and do a tune up like plugs cap fuel filter and clean the carb out next as far as the four wheel drive light i just fixed mine if u have a 90 or later its all vacuum so check the vacuum hoses for leaks the actuator is on the passenger side of the front axle if the line is broke witch normally happens then the light will stay on if it a 91 and newer then theirs a sensor that may be bad or ur stuck in 4x4 if the front actuater is good then theirs a switch on the top of the transfer case that is probly the culpret hope i helped

The jeep is fuel injected so carbs are not an issue. Also I just switched out the spark plugs and oil and oil filter. And I will be getting into the 4x4 problem this weekend!

Navy, thanks for the code list!
 

·
Registered
Joined
·
2,207 Posts
not a problem. when i first got my 94 renegade i also got the air conditioning code with no a/c installed. take care and keep on jeepin'!:punk:
p.s. i had the rpm/stalling problem also. oxegenated gas did it. i ran stp fuel treatment about every 4th tank. the problem went away.
 
1 - 7 of 7 Posts
Top