Jeep Wrangler Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I have a 2002 Jeep tj and so far I replaced the radiator, coolant overflow bottle, water pump, thermostat, heater core, and radiator cap and I still get no heat. Both hoses going to and from the heater core are hot, coolant temp runs between 185-195 and the blend door is operational (took actuator off and moved door by hand). Bled the system normally with the radiator cap off and I even raised the front end and bled the system that way. I’m lost if there’s anything I missed or anyone that has had this problem and has any advice to try I would greatly appreciate it.
 

·
RETIRED MODERATOR
Joined
·
80,065 Posts
Welcome to the Forum, from Cave Creek AZ.
 

·
Registered
Joined
·
612 Posts
I've been battling the same issue on My 2005 X Here is what has transpired: Original Core Heated fine but had seepage & strong coolant smell when using Heater Replaced Heater Core with Spectra Premiun & Replaced Theromstat with 195 degree from Napa Heat barely warm 45 Degree Outside Temp Heat blows 85 degrees on low blower the higher the blower speed the lower the heat output,Blend door & actuator checked multiple times & working correctly,Ordered a second Heater Core Ordered a diffrent brand but in the Box was another Spectra Installed it Zero Improvement,Replaced Thermostat again this Time with OEM Mopar-Still little heat,Replaced Waterpump & All Hoses No Change in Heat Output Bleed Cooling System Multiple times to no avail,Hooked 1st Spectra Core To Heater Hoses Under hood (not installed) top few rows hot rest of core barely warm @ best,Ordered a 3rd Heater Core This One From Advance (Carquest Brand) Hooked up to Hoses under hood just for comparison whole core got good & hot (will complete install on Tuesday,Took Ends off OE Core & Spectra Core Intresting OE Core had stainless coils of wire in each tube as a flow restrictor Spectra Core had Large spiraled plastic inserted in each tube taking up most of the space in the Tubes (will post Pictures soon for comparison) I really wanted a OE Mopar Core but they are discontinued,What Brand was the Core You Used?
 

·
Registered
Joined
·
612 Posts
I will get pictures up of the flow restrictor diffrences tomorrow & hope to swap cores for the 3rd (And hopefully final time) Tuesday
 

·
Premium Member
Joined
·
8,002 Posts
If you are looking for the heater core assembly 5073180AB, Mopar Parts Giant has them. But, they are $220 instead of the $30 to $40 parts that don't work.
 

·
Premium Member
Joined
·
8,002 Posts
Crown has a "direct" replacement for the 5073180 heater core. They use the suffix of AA which would have been the original. The mopar number uses the suffix AB. Quadratec is lower than 4wheelparts, but is currently out. Amazon has a lower price still, and has a few.
 
  • Like
Reactions: gmiller0737

·
Registered
Joined
·
612 Posts
Problem Solved Can’t Recommend Spectra Heater Cores!

Replacement Core didn’t have a problem providing sufficient heat output


Sent from my iPhone using Tapatalk

This is the Core I used Heater Output is fine with this one I guess 3rd time is a Charm it’s a shame it’s so hard to get quality parts nowadays


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
7 Posts
Discussion Starter #14

This is the Core I used Heater Output is fine with this one I guess 3rd time is a Charm it’s a shame it’s so hard to get quality parts nowadays


Sent from my iPhone using Tapatalk

does this heater core have flow restrictions in them that you can tell? And is this the 3rd heater core you’ve gotten from carquest? Or did you get the other ones from somewhere else? Thank you for the replies and the suggestions to try!
 

·
Registered
Joined
·
612 Posts
does this heater core have flow restrictions in them that you can tell? And is this the 3rd heater core you’ve gotten from carquest? Or did you get the other ones from somewhere else? Thank you for the replies and the suggestions to try!
It appears to have the OE Style Restrictors shine a strong light in the top port of the Core if you see those white things I wouldn’t use it,The 2 Spectra Cores came from Rock Auto & I returned a 3rd to Rock Auto ADPI Brand,I only used the one Carquest Core & it works 160-165 degree heat


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
7 Posts
Discussion Starter #16
I guess I’ll go take the spectra heater core out and return it and get the carquest core! Thank you so much for the info! It was driving me crazy trying to figure out why there was no heat! I replaced every part of the cooling system and still nothing! It’s a relief that someone else had this problem and could help me figure it out! Thanks again!
 

·
Registered
Joined
·
612 Posts
I guess I’ll go take the spectra heater core out and return it and get the carquest core! Thank you so much for the info! It was driving me crazy trying to figure out why there was no heat! I replaced every part of the cooling system and still nothing! It’s a relief that someone else had this problem and could help me figure it out! Thanks again!
Shine a good strong flashlight in that top Heater Hose Connection if you see those white Restrictors that’s likely your problem The Carquest must have the OE Style you can’t readily see those by looking into the inlet,I had to order the Carquest one none of the local stores had it so I ordered online shipped to home


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
7 Posts
Discussion Starter #20
Are they not different sizes?

Sent from my SM-G960U using Tapatalk
They are different sizes. The factory service manual says the one coming from the thermostat is the inlet but that hose fits to the outlet on the heater core (or that’s what the website says is the outlet on the heater core)
 
1 - 20 of 24 Posts
Top