Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 12 of 12 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
ive trouble shot my jeep at first i thought it was the fuel pump/ regulator bc it wouldnt start but then after it was towed to the repair shop it started right up,,, Well it wont start again, and i checked the power to the fuel pump and i get power when they key is at the ON position, but when i crank it over to start the power doesnt reach the fuel pump, ive checked the relays im completely lost on what to trouble shoot next,,, does anyone have any suggestions or ideas they would be much appreciated
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
I have a 99 Wrangler 4.0 put a new fuel pump and regulator in yesterday, still won't start. Checked the relay under the hood you can hear and feel it click; went back to the tank and unplugged the plug, getting power at the plug at the gas tank when the key is on; when I turn the key further to engage to start engine, I lose the power.
 

·
Knows a couple things...
Joined
·
49,417 Posts
The ASD relay provides power to the fuel pump relay and the ASD relay will not stay energized unless the ECM (engine computer) is happy with everything like from the crankshaft position sensor.

To me, your fuel pump problem sounds like the ECM is not happy, check your sensors.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
Should I check my crankshaft position sensor and is there any other sensors that should be checked as well?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #6 ·
Well........just replaced crankshaft sensor and it's a no go! Getting ready to call mechanic w/tow truck, any other suggestion would be appreciated, thanks in advace.
 

·
Registered
Joined
·
4,221 Posts
Before I called a tow truck, I would jumper the fuel pump relay.

Checked the relay under the hood you can hear and feel it click; went back to the tank and unplugged the plug, getting power at the plug at the gas tank when the key is on;
Can you hear the pump actually running?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #8 ·
What we ended up doing is running an external ground from the fuel pump harness to the chassis and the guy that did it believes that my computer is on it's way out; is there any way to check computers or is it just an automatic replace?
THANKS EVERYONE FOR YOUR HELP!
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #10 ·
well what controlls the ground to the fuel pump does anyone have any ideas so i can fix it for the long haul instead of a quick fix??
 

·
Registered
Joined
·
11 Posts
im having the same issue with my 99 sahara. it wont turn over and the computer is saying no bus bu5. what did you have done to get it started. was it an electrical shortage?
 
1 - 12 of 12 Posts
Top