Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 14 of 14 Posts

·
Registered
Joined
·
1,973 Posts
Looks like a faulty gasket to me
 

·
Registered
Joined
·
336 Posts
I actually had that exact same issue a couple months ago. Rear main seal was blown (16k on a 2015!). Dealer had it for 3 1/2 weeks replacing it under warranty
 

·
Registered
Joined
·
336 Posts
They fixed it under the it's barely a year old and I would have ripped them a new one warranty. haha I would think it would be covered under all the manufacturer warranties.
 

·
Registered
Joined
·
133 Posts
Looks like that drain plug at the top of the picture (oil pan?) is leaking a bit, too.
 

·
Registered
Joined
·
2,853 Posts
Is it a '14? I was talking to a jeep tech today that said eventually two little plugs on the side of the oil filter housing will eventually start leaking. Fwiw he said he pretty much never sees any common problems with the '14's so that made me feel better.
 

·
Registered
Joined
·
616 Posts
Mine leaks in the same area, I have a dealer appointment , hope they don't deny me for my lift and tires :(
 

·
Registered
Joined
·
3 Posts
Is it a '14? I was talking to a jeep tech today that said eventually two little plugs on the side of the oil filter housing will eventually start leaking. Fwiw he said he pretty much never sees any common problems with the '14's so that made me feel better.
I have a '12 with just under 60k that has oil leaking from those plugs. I haven't played with them yet, but I saw them described as inspection ports somewhere? I'm taking it to the dealer this Friday.
 

·
Registered
Joined
·
616 Posts
Tell me how that goes. I'm planning on making an appointment for next week.
well my app isnt until the 23rd because I have to wait until a Saturday soo... if you go before me, let mew know :D
 

·
Registered
Joined
·
43 Posts
Oil Leak

I also have an oil leak. I've heard it is the rear main seal from a couple of buddies down here but I wanted to see what the everyone on here thinks. I was out wheeling and hit a tree stump with my transmission cross member. I was going about 5 mph and it brought me to a dead stop and left a nice crescent moon shaped dent in the cross member. When I went and replaced the cross member with a rough country heavy duty cross member, that is when I noticed the leak. I still have the factory warranty and an extended warranty but I don't know if it will be covered because I changed out the cross member. Here is a picture of where the leak is coming from. It is a 2014 JKU 6 speed manual.
 

Attachments

1 - 14 of 14 Posts
Top