Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I had my oil changed recently and they said that they reset the oil light, and lo and behold it lit up my board a few short hours later. I've done it previously and I was able to do it just fine, however, I have been unable to do it this time and I can't figure out why. I am putting it into the "on" mode (not accessory), without turning on the engine, and pressing the accelerator three times within 10 seconds before turning it back to the "off" position. I've tried pressing the pedal down fast to really slow hoping it would do something, but it is still flashing.

Any help would be appreciated. My damn tire warnings have been going off since I got the car, probably since the tires are not original, and I don't need another annoying warning popping up every time I start the car. I'd turn both off for good if I could, but since I can't, I'll settle for just the oil warning

2012 Wrangler
 

·
Retired Moderator
Joined
·
100,487 Posts
Try removing your battery cables. Hold the ends together for about 30 seconds and then reconnect. That should reset your system.
 

·
Registered
Joined
·
1,210 Posts
You are talking about the change oil light I hope? Not trying to be rude but could you mean the oil pressure light? Maybe they didn't fill or put oil in, not too trusting of some places.
Check your oil level.
 
1 - 3 of 3 Posts
Top