Jeep Wrangler Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
142 Posts
Discussion Starter #1
Something odd just started happening with my 2004 TJ, the oil pressure gauge will drop to zero, it flashes the "check gauges" light and beeps, then it goes right back to normal operating pressure before i even have a chance to pull over or kill the ignition.

It has only happened a few times so far, like 3 or 4, I've only observed it within the first few minutes of driving it. While it's due for an oil change anyway, it never occurred before replacing the battery 2 weeks ago. I haven't yet been able to identify any similar factors between incidents (like right after shifting to 3rd, braking, during hard turns, or whatever).

While I guess it could be related to the battery swap, I don't see any other indicators that the battery is bad or in any way goofy. So my initial thought is a loose wire on the Oil Sending Unit, or a bad unit altogether. Since I'm not going to have a chance to dig into it until next weekend so I thought I'd run this by you guys in case one of you have had this exact same problem and would care to share the fix.

Barring specific input, this is what I plan to do next weekend.

- Replace Oil Sending Unity
- Change Oil and Filter
- Check the wiring for any obvious problems

Thanks in advance for any input!
 

·
Registered
Joined
·
2,260 Posts
get the factory OEM oil pressure switch. The ones at the parts box stores are garbage.

I found that mine does it once my oil gets close to time to change the oil.
 
1 - 2 of 2 Posts
Top