Jeep Wrangler Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
105 Posts
Discussion Starter #1
My oil pressure is all over the place new oil pump new pressure switch new oil filter new oil. At ideal it about 20 running down the road it 60 psi. I even put the old pressure switch back on and same thing. Any ideas on what it could be I was told its time for a rebuild. That the bearings are getting to much play but I would think you would hear that like a rod knocking
 

·
Registered
Joined
·
1,610 Posts
Try taking the gauge cluster down and clean every contact really good. Also make sure your grounds are good. Grounds are your best/worst enemy!
 

·
Registered
Joined
·
51 Posts
Running close to mine . . . Have a 92 2.5L, at initial start runs at 60, will drop some to around 50 (min.) at running temp., idle at running temp., just around 30, give or take.
 

·
Registered
Joined
·
105 Posts
Discussion Starter #4
I read something on the great net that says as long as its above 13 at ideal you are good to go but seems low to me. It's still runs good. If it blow it will just give me a reason to buy a new one
 

·
Registered
Joined
·
725 Posts
I read something on the great net that says as long as its above 13 at ideal you are good to go but seems low to me. It's still runs good. If it blow it will just give me a reason to buy a new one
Any pressure is a positive thing. LOL!
 

·
Registered
Joined
·
374 Posts
I have 155'000+ on my 89 2.5 and oil pressure at idle (warm) 30, 4th gear @ 45-50mph around 60.
 

·
Registered
Joined
·
3,939 Posts
My oil pressure is all over the place new oil pump new pressure switch new oil filter new oil. At ideal it about 20 running down the road it 60 psi. I even put the old pressure switch back on and same thing. Any ideas on what it could be I was told its time for a rebuild. That the bearings are getting to much play but I would think you would hear that like a rod knocking
that is not unusual..warmed up engine with 20 pounds at idle is okay and then for it to jump to 60 with the rpm's up is normal too..it just indicates that your engine does have some wear but it may still have a lot of miles in it
 

·
Registered
Joined
·
274 Posts
my oil pressure stays steady at 30 pounds, sometimes i'll push 40 pounds but other than that im pretty much dead on 30 UNLESS I turn the heat on during the winter. Any thoughts on this?
 

·
Registered
Joined
·
3,939 Posts
my oil pressure stays steady at 30 pounds, sometimes i'll push 40 pounds but other than that im pretty much dead on 30 UNLESS I turn the heat on during the winter. Any thoughts on this?
you may have a sending unit/gauge problem...normally oil pressure will fluctuate more than that with temp and rpm's
 

·
Registered
Joined
·
3,939 Posts
if it is time for the oil and filter to be changed then do that..I always use 10w-30..if it is not due a change then at least make sure the oil level is where it should be
 

·
Registered
Joined
·
742 Posts
If it still runs well as you originally stated, why not just invest a couple of bucks in a new sending unit? Easy fix and I think you may be pleasantly surprised.
 

·
Registered
Joined
·
105 Posts
Discussion Starter #17
That's my next step. Just looking at grounds and wiring to see if I have a problem with any of that. Cleaned the cluster out as well
 
1 - 18 of 18 Posts
Top