Jeep Wrangler Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter #1
Hey all, first time poster!

I have a 94 Sahara with a bit of a problem: I have an oily air filter, like its coming back out of my intake. Im not sure if this is a problem related to valves or piston rings. Also my engine makes a bit of a grumbling while running, the engine runs and idles completely smooth but I guess the only way to describe it is that the engine sounds somewhat like a diesel engine, more from the underneath which would lead me to believe its rings. Maybe its both, any expert ideas?

Thanks for your help, I will definitely be around the forums!
 

·
Registered
Joined
·
145 Posts
Have you checked for an exhaust leak? That could be causing the grumbling you describe. The exhaust manifolds on the YJ are proned to cracking around the 2-into-1 "Y". as for the oil in the filter, is it the whole filter or just parts of it? The 4.0 tends to spew a little oil from the crank case ventilation hoses that connect to the filter box.
 

·
Registered
Joined
·
70 Posts
Discussion Starter #3
Wow, so many things i havent thought of!

Its just around the middle of the filter, basically directly below where the intake tube is.

Thanks a ton, Ill be checkin for cracks when I put my new shocks on later!!!!
 

·
Registered
Joined
·
145 Posts
We're here to help. Also check the usual while you're at it; PCV, vacuum lines (wouldn't want any cracked ones getting worse), plugs, wires, cap, rotor button, fuel filter...etc... Anytime I go into anything on mine I always check the basics before I close it up.
 

·
Registered
Joined
·
70 Posts
Discussion Starter #6
Perhaps that would account for something else it does at well? A lot of times when I start driving, it will start this kind of fluttering noise under the hood that that goes up and down with the accelerator. After maybe 10 minutes it goes away and doesnt start again until I have to restart it another time.

Will deffinitly get the valve among other things today. You guys are great.
 

·
Registered
Joined
·
4,057 Posts
He's wrong. Is Checker some kind of auto place? If so, don't do business there anymore.
 

·
Registered
Joined
·
70 Posts
Discussion Starter #9
Yeah its an auto place, not the best but its right across the street.

I am having a tough time even finding one online......any idea where to find one? All I can find is one for a 4cyl and an elbow for a 6..........sorry Im being such a pain......
 

·
Registered
Joined
·
4,232 Posts
You are not being a pain...this is why we are all here. By the way, I love the color on your Jeep. You should be able to get the PCV valve from any real parts store. You could order it online at Autozone, Advance, or a Jeep place like Quadratech.
 

·
Registered
Joined
·
70 Posts
Discussion Starter #12
Replaced that and my vacuum lines and its still doing the same thing. Im not sure what to do next....I replaced plugs, wires, cap, rotor........oh, and I noticed my battery power is going down little by little, Im almost at a quater on the gauge. Is this the battery or alt., or will I need to have them tested to find out?


Thanks to everyone
 

·
Registered
Joined
·
4,057 Posts
Get them tested (it's free), but the alternator generally works or doesn't work. If your battery is charging, then your alternator is good. You can make sure the alternator is good your self by cranking the vehicle and then disconnecting the battery, If it doesn't quit, then your alternator is good.
 

·
Registered
Joined
·
90 Posts
well on my 94 i do not have a PCV valve. it is just an elbow. i always have just a little bit of oil on my filter. but sense i replaced the intake and exhaust gasget. it has quited down a lot. i don't know if that will help you but you might want to look at it
 

·
Registered
Joined
·
3,260 Posts
Looks like daddyjeep uses Pacesetter Headers. Don't be afraid of using the internet to search and compare different products. You have the world at your finger tips.
 

·
Registered
Joined
·
4,232 Posts
My Pacesetter header is OK. If I had to do it over again I would go with something different. They did help with the Hp and they sound great, but the quality isn't quite top notch. There is a ball and socket type flange right under the oil pan that was a real p.i.t.a. to get together without leaking. I have been running them for four years now and they have performed well, so not that bad. They are relatively inexpensive so if they are all your budget allows then go for it.
 
1 - 20 of 24 Posts
Top