Jeep Wrangler Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Hi i recently installed a 4 way amp in my jeep. For the first week it worked great. Now however one speaker often plays way louder than the rest but not always. It also sometimes makes a bunch of static noises. I know the speaker is good because I've switched the speakers around on the amp. What ever speaker i plug into my rear left port on my amp is the affected one. Also i checked all the wiring and it all seems good. Please help!
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
I did try that. The volume is still louder in the same out terminal no matter what rca is pluged in.
 

·
Premium Member
Joined
·
2,939 Posts
The symptom is that one speaker sounds louder, now what we have to do is find the cause; find out why.

Before you swap speakers make sure your speaker wire ends are in good shape and that there are no stray strands of wire sticking out. Make sure they are cleanly and solidly place in their respective connectors.

Once you have absolute confidence in the wire, swap the speaker wires to the speaker is on the opposite channels. That should help you determine whether it is the Amp or the Speaker.

Also, if you have a Mono switch on your Amp, switch it to Mono while you listen for a while. IF the sound is roughly the same in Mono, that would indicate the problem is with the signal source (DVD, CD, Phono, Tape, etc...). Sadly most new amps do not have a mono switch.

If you swap speaker and the problem stays on the same channel. Then you have to do the same thing with you signal source. If you are playing a music CD, then you have to swap the output of the CD. Left channel to right, right channel to left.

And just to save yourself a lot of headaches, make sure the balance control is set to center. It could be as simple as someone messing with the controls.

By swapping things around (one at a time), you should be able to isolate the problem.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
i havve tried all of that stuff. Sometimes i go in the jeep and the speakers are all the same volume. Other times that one speaker is a lot louder. Also sometimes the speaker will start out loud but if i quickly crank the volume up it will go back to normal with the other speakers.
 

·
Premium Member
Joined
·
2,939 Posts
maybe a bad channel or a loose connection with in the amp
 

·
Premium Member
Joined
·
2,939 Posts
It's a process (and a pain) glad you got it sorted out
 
1 - 9 of 9 Posts
Top