Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 11 of 11 Posts

·
Registered
Joined
·
131 Posts
Discussion Starter · #1 ·
So the jeep overheated while highway driving in cool weather. Reached 260 and pulled over and waited until it cooled to 210 and below. What would you replace now? 177,000 miles on the engine.

Now I checked the cap today and it is rusty inside. So I'm planning on a coolant flush for the block and possible radiator replacement.

If I'd have to replace something else maybe the thermo and water pump?

Eerie thing is... the radiator on the outside ( fins ) didn't feel hot to the touch this morning when i drove it to work. It's about a ten minute drive. And there's a mild to slow drip on the lower hose near the clamp (replace this tomorrow).
 

·
Show Me Your 8008135!
Joined
·
3,690 Posts
I'd pull your thermostat and boil it in water and see if it opens or is stuck closed...and pray that's all it is. Not sure after that...never dealt with that issue before.
 

·
Registered
Joined
·
583 Posts
I would do radiator water pump hoses and thermostate change they are all cheap except the radiotor bu ur planning on doingbhat anyway. And check fan clutch if its weak that could be it. But with that millage the jeep deserves all that.
 

·
Registered
Joined
·
131 Posts
Discussion Starter · #5 ·
yeah...hmm...more shiny new parts ;) hopefully its just these few things
 

·
Registered
Joined
·
131 Posts
Discussion Starter · #6 ·
oh btw when I do flush the system, but my air conditioner and heat doesnt work/blow air--does this matter?

the belt spins the a/c sytem but the darn thing doesn't turn on...never did since I owned it.
 

·
Registered
Joined
·
131 Posts
Discussion Starter · #7 ·
Omg !!

There wasn't even a frigin thermostat!!!! The radiator was blocked and in goes a freshy!! Whoa
 

·
Registered
Joined
·
892 Posts
oh btw when I do flush the system, but my air conditioner and heat doesnt work/blow air--does this matter?

the belt spins the a/c sytem but the darn thing doesn't turn on...never did since I owned it.
doesnt blow air on all settings or just the lower three?
check fuse, blower motor, and fan speed resistor.
 
1 - 11 of 11 Posts
Top