Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 15 of 15 Posts

·
Registered
Joined
·
312 Posts
Discussion Starter · #1 ·
My CHeck eng light came on.... ran the code and came up with the above. I have an 03 Inline 6 ..... how do I know which sensor is bad / to replace ... also where are they located .... thanks
 

·
Registered
Joined
·
312 Posts
Discussion Starter · #3 ·
thanks.... where on this diagram above is it located ?
 

·
Commercial Member
Joined
·
5,792 Posts
thanks.... where on this diagram above is it located ?
Also here is a 5% discount code for rockauto

1574541712895315

Using Your Discount Code

Enter the code above in the "How did you hear about us" line of the shopping cart. If you are using our traditional HTML catalog, please click the "Apply" button to the right of the field. Your discount will automatically appear, subtracted from your parts order total. Orders using discount codes must be placed online. Phone orders are not eligible for discounts.

Please note: We sometimes get calls from people who put the word "discount" in front of their code and do not get the discount. Please enter ONLY the discount code, no other words or numbers. Code must be entered before order is submitted to receive discount.

The discount takes 5% off our already-low prices. There's no limit on order size or the number of orders. Use the code for your next order, and share the code with friends, neighbors, relatives, the guy at the corner garage--anyone you know who works on cars or trucks.

This discount code expires on August 25, 2013; so don't wait![/QUOTE]
 

·
Registered
Joined
·
312 Posts
Discussion Starter · #6 ·
thanks.... I was not able to find that part number listed above 23138 ???
 

·
Registered
Joined
·
312 Posts
Discussion Starter · #9 ·
Ty !!!!
 

·
Registered
Joined
·
2 Posts
My CEL came on about a week ago and was reading P0155, so I replaced the bank two - sensor one and cleared out the code. Good news
 

·
Registered
Joined
·
2 Posts
2004 Jeep Wrangler X, Automatic

My CEL came on about a week ago and was reading error P0155, so I replaced the bank two - sensor one (with NTK part) and cleared out the code. Good news is...the error code is gone, bad news is...I've actually lost gas mileage.

I was getting about 16 mpg (16.5 max) before the sensor went bad and about 13 mpg when the CEL came on. After the change I'm getting about 12-13 mpg average. Shouldn't the mpg have gone back up again after the fix?

Note: I live in the northeast and it has been MUCH colder out the last few days. Could this attribute to the loss as well? My jeep is garaged and not sitting idling to warm up but I don't know if other cold factors come into play.

Any thoughts or suggestions on cause or possible fixes would be much appreciated. Thanks all.
 

·
Registered
Joined
·
20 Posts
I have the P0155 code come on while trying to fix a misfire condition. Will the O2 sensor cause a miss?
 
1 - 15 of 15 Posts
Top