Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
On my 07 Unlimited X we cooling issues to find out the radiator had a leak. So replaced the radiator and thermostat. Then the temp gauge wasn't reading correct so we replaced that and it was good. Until Winter hit. What was happening was the electronic cooling fan was on high all the time and any time we were at idle the heat would turn to cool air in the car and the engine temp would drop but would warm up once driving again. Found plugged trans cooler causing the fan to run on high and over cooled the engine coolant. NOW I have codes P0218 and P2181 the engine temp goes down a little at idle but the fan cycles like normal. Smell of trans fluid after driving. its full but has a burnt smell (not the worst ive smelt). Drives like normal no shifting issues. Im stumped and cant seam to figure this one out. any ideas?
 

·
Premium Member
Joined
·
655 Posts
If I were you, I'd plug in a scanner...jscan or something that could look at live data. Then look at the coolant data PID. Does the temp look rational? Keep in mind the guage on the dash is what the cluster thinks based on messages from the PCM. Would be better to see what the PCM is seeing through scan data. Guess I am wondering if gauge that was replaced was ok, but the coolant temp sensor isn't reading right so the PCM is taking action based on an incorrect temp. Both the codes are cooling temp related. If the thermostat is good (just cause it's new, doesn't mean it's good) then I'd check to see if the temp sensor is reporting correct temps back.
 
1 - 2 of 2 Posts
Top