Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 6 of 6 Posts

·
Registered
Joined
·
816 Posts
Discussion Starter · #1 ·
Searched for error code P0303 all over and I find a lot of posts pertaining to older models, but nothing for the 2005. So I will ask.

I have a 2005 Wrangler X with ~89,000 miles, every so often (kinda vague, maybe once every 3-4 days) I get a very short stutter at idle kinda like its going to die, by the time I look at the tach it is idling at 6-700 RPM smooth. Today it happened twice.

Tonight, driving to a meeting and the check engine light came on, when I stopped I checked the gas cap, it seamed okay. When I got home I pulled the codes and got a P0303 misfire cylinder #3.

Service history is a black hole, I have had the Jeep about 7 months without a problem.

Where to start? I've seen a lot about certain plugs, coil rail, Crank Position Sensor, etc. Where should I start? Since I don't know the history, I was thinking new plugs to start. I hear that Autolite AP985, XP985 or Champion 7034. Is this a good start? Or do I need to look elsewhere?

Thanks for the help,
John
 

·
Registered
Joined
·
816 Posts
Discussion Starter · #2 ·
Also, am I okay to continue to drive with this until I get it figured out?
 

·
Registered
Joined
·
816 Posts
Discussion Starter · #4 ·
I searched here, mostly pre-2005 references, didn't think of Google, doh!

CEL was out this morning. I am going to start simple and replace the plugs tonight with some Autolite AP985 or XP985, depending on the discount I can get at NAPA. Will be interesting to see what the current ones look like, could have 5k miles or 89k miles on them.
 

·
Registered
Joined
·
816 Posts
Discussion Starter · #5 ·
CEL is still off, but something is still not quite right judging by the stuttering I get occasionally. I picked up the Autolight plugs last on my way home from work, but they gave me the regular 985 instead of the AP985. Daughter needed help with Algebra, will have to wait until the weekend. I am really curious to what the old plugs will look like.
 

·
Registered
Joined
·
31 Posts
What your going through, Ive been through. now mine is even worse.. if you have a 05 google code P0344 in 04-05 Jeep put out a real POS and the OPDA is junk and wipes out the cam gear. looks like there is a recall on these. im calling a jeep dealer today to find out more info. Not saying this is your problem, but thats how mine started out.
 
1 - 6 of 6 Posts
Top