Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 11 of 11 Posts

·
Registered
Joined
·
109 Posts
Discussion Starter · #1 ·
Ok guys. I purchased this unit off a member here a few days ago. He has indicated that he had replaced his factory 430 unit with this one and everything was ready to do in terms of plug n play.

I do not have the alpine unit myself. I have factory controls on the steering wheel but mine has the base radio.

Is there any issues you guys can see with the plug n playability of this unit, considering it's going from his stereo (430) to mine (base stereo)
 

·
Registered
Joined
·
922 Posts
I had the 130 base radio and steering wheel controls. Put in a pioneer 4200 and you have to add the idata maestro unit for steering wheel controls. Also there is a CH1 harness that is needed.

So, as far as I know, even the 8100 isn't just 'plug and play' as far as the steering wheel controls.

I believe PAC also makes a module for SW controls but I do not have any experience with it.
 

·
Registered
Joined
·
109 Posts
Discussion Starter · #5 ·
Got it installed today. Really a game changer over the stock base unit. Now on to some new speakers
 

·
Registered
Joined
·
109 Posts
Discussion Starter · #7 ·
I installed it myself. Took about 45 mins for everything. I didn't get the rear camera ran all the way yet but everything is hooked up.

So everything was 450
 

·
Registered
Joined
·
4 Posts
Hi! What kit did you use to install the AVIC? Right now I'm not able to screw in that screw on the top of the dash down into the stereo kit to hold the dash in place...
 

·
Registered
Joined
·
6,718 Posts
Hi! What kit did you use to install the AVIC? Right now I'm not able to screw in that screw on the top of the dash down into the stereo kit to hold the dash in place...
I never got my top screw back in either after my install. That was a while back. No issues to this day. The dash front should have clips on the front. This seems to be enough to hold mine in just fine.
 

·
Registered
Joined
·
143 Posts
Hi! What kit did you use to install the AVIC? Right now I'm not able to screw in that screw on the top of the dash down into the stereo kit to hold the dash in place...
I took the metal support that the top dash screw attaches to out and cut the bottom portion off so I could bolt it back in place and still used the top screw.
 
1 - 11 of 11 Posts
Top