Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 20 of 30 Posts

·
Registered
Joined
·
568 Posts
Discussion Starter · #1 ·
So hear I am going 70 down the highway, stepped on the gas to pass someone. looked at the rpm gauge and it was a 0. my truck stalled and almost went into the guard rail. coasted down the shoulder once I hit 30 my truck then restarted by itself and back fired a couple times. I couldn't help but laugh at what was going on:rofl: one It stopped I let it sit then it started back up and made it home fine. any ideas to what it is?
 

·
Registered
Joined
·
742 Posts
You're parents must have put a 70 MPH governor on it so you don't hurt yourself. Unit makes you come to a complete stop to give you time to come to your senses. They just care
 

·
Registered
Joined
·
568 Posts
Discussion Starter · #4 ·
HAHA! They were in the passenger and back seat. My mom said "oh here we go again" it was in jersey too. I had to go fast it was drizzeling and I had no top on. My jeep only drives nice on the high way. and I will put some seat covers on the list along with some pampers cruisers
 

·
Registered
Joined
·
742 Posts
Yup. Mom put it in for sure.
 

·
Registered
Joined
·
335 Posts
blinker fluid is over filled
 

·
Registered
Joined
·
118 Posts
What about headlamp fluid?

Red Vs Blue jokes aside I would start looking for bad grounds, corrosion and shorts in the ignition wires.
 

·
Registered
Joined
·
1,610 Posts
Although all these are hilarious, check your relays. Ign and auto shutdown. My ignition relay was bad a few years back and would only go out on the highway while hitting a bump. Same symptoms too.
 

·
Registered
Joined
·
568 Posts
Discussion Starter · #14 ·
NO way! I just put in royal purple blinker Fluid!. Hmm I just gutted my cat the bearings did look ok though. I think my Carburetor crankshaft is bad. has a slight wobble. I tried starting up my truck at night and seen some arching and I think I might have an intake leak.
 

·
Registered
Joined
·
257 Posts
NO way! I just put in royal purple blinker Fluid!. Hmm I just gutted my cat the bearings did look ok though. I think my Carburetor crankshaft is bad. has a slight wobble. I tried starting up my truck at night and seen some arching and I think I might have an intake leak.
Possibly a flux capacitor. Did you change your fluid yourself? Did you do it at operating temp? Both sides equal? It's a tricky process and can ruin your jeep.
 

·
i'm back
Joined
·
13,706 Posts
NO way! I just put in royal purple blinker Fluid!. Hmm I just gutted my cat the bearings did look ok though. I think my Carburetor crankshaft is bad. has a slight wobble. I tried starting up my truck at night and seen some arching and I think I might have an intake leak.
spray some brake clean around the manifold... it should stall right away if you have an intake leak... :thumb: or it could be the previously mentioned flux capacitor. if you're not getting the right voltage from lightning strikes.. that can happen.. :whistling:

 

·
Registered
Joined
·
568 Posts
Discussion Starter · #17 ·
yeah I did. It's really a time machine now. Not sure, the wonderful people at pepboys changed it for me. I have always had my fluid changed every 100,000 blinks.
 

·
Registered
Joined
·
163 Posts
What about the air color in the tires? Purple is for slow, Red is medium speed and then there's PLAID for the super fast speeds...
 

·
Super Moderator
Joined
·
9,601 Posts
yeah I did. It's really a time machine now. Not sure, the wonderful people at pepboys changed it for me. I have always had my fluid changed every 100,000 blinks.
If its a time machine... Simply go back in time BEFORE the problem started and everything should be fine! :thumb:
 

·
Registered
Joined
·
568 Posts
Discussion Starter · #20 ·
Im gonna go back to when jeep was designing the YJ and kill them for adding all this emissions BS and for the carter carb
 
1 - 20 of 30 Posts
Top