Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 20 of 26 Posts

·
Registered
Joined
·
964 Posts
Discussion Starter · #1 ·
So guys I have an odd new popping noise, I just came back from a 2 week work thing and as I'm dropping off my buddy at his place I'm pulling out to the left there is a loud pop and when I get home I turn it all the way right and left when it goes to turn left there's a quieter pop not sure if it is the steering assembly joints or if my steering box just slipped or what it is but I'm not liking it, anyone else experience this and fix it?
 

·
Registered
Joined
·
446 Posts
Good idea anything else that could cause that noise that I didn't think about?
Sway bar links, TREs, control arms, most components can cause that. Do a dry steer test and see if anything is shifting.
 

·
Registered
Joined
·
964 Posts
Discussion Starter · #5 ·
Sway bar links, TREs, control arms, most components can cause that. Do a dry steer test and see if anything is shifting.
Hey thanks guys, will try it out tomorrow and see what it could be hopefully it's my drag link, been wanting an excuse to get a heavy duty set lol
 

·
Registered
Joined
·
608 Posts
I am also trying to track down a popping noise on slow left turns. Did have play in both drag link ends, replaced with Moog parts. Also replaced front lower control arms and axle u-joints. Popping is not yet cured. Next step is to remove the diff cover and inspect the gears.

If you're going to beef up your steering I do not recommend the crown kit. I've had to replace both tie rod ends and the drag link in less than a year and a half. Just get the zj tie rod and get Moog parts. If I had to do it over id probably just go with the Currie steering. The crown drag link is not really an improvement over the stock tj one, heavy duty wise.
 

·
Registered
Joined
·
32 Posts
Are you sure that you don't have a locker installed in your front axle. I installed a Spartan and it will pop loud on tight turns, like turning to park and its totally normal.
 

·
Registered
Joined
·
964 Posts
Discussion Starter · #8 ·
Are you sure that you don't have a locker installed in your front axle. I installed a Spartan and it will pop loud on tight turns, like turning to park and its totally normal.
Dude. Trust me I don't have a locker I wouldn't be asking questions about popping if I did. And I wouldn't be confused about it
 

·
Registered
Joined
·
964 Posts
Discussion Starter · #9 ·
I am also trying to track down a popping noise on slow left turns. Did have play in both drag link ends, replaced with Moog parts. Also replaced front lower control arms and axle u-joints. Popping is not yet cured. Next step is to remove the diff cover and inspect the gears.

If you're going to beef up your steering I do not recommend the crown kit. I've had to replace both tie rod ends and the drag link in less than a year and a half. Just get the zj tie rod and get Moog parts. If I had to do it over id probably just go with the Currie steering. The crown drag link is not really an improvement over the stock tj one, heavy duty wise.
Guess what kit I already had installed prior to the noise about a year ago? Lol if you find anything in your diff let me know! I'm following your thread too as I'm very busy this weekend and won't have time or my garage to look at it
 

·
Registered
Joined
·
608 Posts
Guess what kit I already had installed prior to the noise about a year ago? Lol if you find anything in your diff let me know! I'm following your thread too as I'm very busy this weekend and won't have time or my garage to look at it
Argh Crown!! I'm hoping to pop the cover today. I'll report back.
 

·
Registered
Joined
·
608 Posts
Diff cover is off, everything looks good to my untrained eye. No metal chunks or shards. But I have a zip locker so I can't really see much. Just the ring and pinion. Gear teeth look okay. I'll probably jack up the front end and spin the tires a little to look at all of them. Whole lot of metallic flecks in the gear oil, but as far as I know that's normal. Anything else I should be looking for?
 

·
Registered
Joined
·
964 Posts
Discussion Starter · #13 ·
Diff cover is off, everything looks good to my untrained eye. No metal chunks or shards. But I have a zip locker so I can't really see much. Just the ring and pinion. Gear teeth look okay. I'll probably jack up the front end and spin the tires a little to look at all of them. Whole lot of metallic flecks in the gear oil, but as far as I know that's normal. Anything else I should be looking for?
I don't know if the flakes are normal I'm gonna look into that... but honestly our misery popping isn't making much sense.. I think I'm gonna do a once over on the tie rod and drag Ling ends again, then I'm gonna feel up my steering box, that might be our issue maybe the steering box is just slipping or something crazy
 

·
Registered
Joined
·
1,031 Posts
Did you check the trackbar frame bolt? My end went bad and the bolt loosened up which caused a pop in the steering. Just had to tighten it. Jack the front axle off the ground and have someone steer back and forth while you watch
 

·
Registered
Joined
·
608 Posts
They definitely weren't flakes, just like metallic dust throughout the gear oil. The gears only have 5K miles on them and I was told that was normal for new gears. Looked like that after 500 miles too when I did the first gear oil change after the regear/lockers, as was expected.

I have retorqued my trackbar since this started as well. What trackbar are you running Dsallows? I have the metalcloak. It has a heim joint at the frame end and I have read they can be noisy and originally thought that was my issue. I've lubed it with silicon lube many times since and it hasn't cured the problem. Also read that if they are torqued too tight (150 ft. Lbs per metalcloaks instructions) it can deform the joint and make it creak. I backed it off about an 1/8 of a turn with my breaker bar, we'll see if it has any effect. Maybe I had overtorqued it originally?
 
1 - 20 of 26 Posts
Top