Jeep Wrangler Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Im sharing this post for informational purposes but if anyone has insight/advice/feedback, I’m listening.

Background:

I had a broken power steering pump bracket for a while now. It’s been that way since I got my Jeep a little over a year ago. Everything seemed fine despite the clear break leaving one of the bolts on the bracket essentially useless, but the remaining bolts seemed to hold it in place. I had a water pump go bad, so I replaced several things in that region, including the belts. After reassembling and tightening everything, I decided to leave the bracket since it didn’t seem to cause any issues. I should’ve fixed the broken bracket then but I couldn’t find it in any parts stores and I didn’t really want to waste more time and money on it.



Everything was fine for the last 5 months until now, I started to get squeeling from the belts every time I started it. I tightened the belts once and the problem went away for a few weeks, then it came back. I made an attempt to tighten the power steering pump/ water pump belt and ended up breaking a tiny little alignment notch the keeps the brackets straight on the power steering pump mount. Needless to say, I need a new bracket now.

These brackets are not easy to find. You’ll never find one locally, the nearest possibility for me would be a 1.5hour drive to a junkyard in the sticks, and it’s still a maybe. It seems the only way to get it is to order it, and it’s about a $90 piece of aluminum. I’m not sure how the original break happened but if I had to guess I would say someone was trying to tighten the belt and overdid it. The little chip that I broke off took almost no effort to break. I simply used a wrench for leverage to pull the belt tight and it snapped, so I think that the metal was brittle. Maybe the engine heat cased it to become brittle over time? Who knows, all I know is I’ll be extra careful when I get the new one.

Im not quite sure the method to tighten that belt, or how to adjust the power steering pump mount to tight it, so if anyone knows how, please advise. I don’t want to break the new one.
 

·
Registered
Joined
·
73 Posts
Very curious what this little alignment notch is that you broke off. Any way you could post a photo? Either of the broken piece, where it broke from, or even by pointing it out from another photo of an intact mount you found online? Thanks
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #3 ·
Very curious what this little alignment notch is that you broke off. Any way you could post a photo? Either of the broken piece, where it broke from, or even by pointing it out from another photo of an intact mount you found online? Thanks
The part I circled is the “notch” I broke off. The line in blue is the part that was broken since I got it (I didn’t break it or know how it was broken). The bracket is a two piece part, the pictured part is on one side and there’s a smaller bracket, basically the same thing but without the part that was broken on mine to begin with, on the other side. The bracket had a notch to fit into the other side. The “other side” is the side with the belts, on the front of the engine.
 

Attachments

·
Los Angeles
1993 Wrangler YJ 4.0
Joined
·
2,219 Posts

 

·
Registered
Joined
·
18 Posts
Discussion Starter · #5 ·

Yep, these are the parts.

If anyone has has installed them please share your experience/ how you tighten the bracket and belt. There are several bolts holding it on and I’m not sure which to tighten first and which to leave loose to adjust the belt. It just doesn’t make sense to me.
 
1 - 9 of 9 Posts
Top