Jeep Wrangler Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
I installed the TF kit with the Rancho lower arm brackets today on my JKRU. I like the ride but apparently we created a new problem.

On first test drive the traction contol seemed to be kicking in/out...after a few blocks the amber tc light came on and stayed on. Drives fine as long as the ight is on but I think whats happened its its disabled the tc system.

My first guess is that I damaged one of the wheel speed sensors or wiring. But I could not see aything obvious.

Also I hate the way the brake lines pass between the springs and the shocks on the front. I bught a set of front adapterrs from somewhere and they are just a piece of flat stock with 3 holes that moves the factory braket up a bit but still verry very close to the springs and shocks. Ther must be a better way

Any advice on eitherr of these issues would be appreciated
 

·
Premium Member
Joined
·
432 Posts
I installed the TF kit with the Rancho lower arm brackets today on my JKRU. I like the ride but apparently we created a new problem.



On first test drive the traction contol seemed to be kicking in/out...after a few blocks the amber tc light came on and stayed on. Drives fine as long as the ight is on but I think whats happened its its disabled the tc system.



My first guess is that I damaged one of the wheel speed sensors or wiring. But I could not see aything obvious.



Also I hate the way the brake lines pass between the springs and the shocks on the front. I bught a set of front adapterrs from somewhere and they are just a piece of flat stock with 3 holes that moves the factory braket up a bit but still verry very close to the springs and shocks. Ther must be a better way



Any advice on eitherr of these issues would be appreciated


Silly question, but your steering wheel is centered, right?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
Was going to do that first thing in morning. Could it be that simple? I hope so. Just ran out of time tonight. Please tell me its that
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
Thanks everyone...what a relief. Will get er done in AM
 

·
I AM THERE4 I JEEP
Joined
·
12,295 Posts
Yep it's most likely then the off centered steering wheel. That will trigger the TCS. You can center it in 10 minutes in your driveway. Just loosen and the adjust the draglink bracket underneath, it's very simple.
 

·
Registered
Joined
·
2,025 Posts
same thing happened to me after my install. Came to the forum for help, was told to check steering wheel. Yup not centered, after centering it in the ball park all was well. Even though my steering wheel was not perfectly centered it got centered after I took it to a shop for alignment. And don't forget to re-torque every thing
 

·
Registered
Joined
·
1,401 Posts
I pulled my front break lines out of the lower bracket s and zip tied them to one of the shocks. Sure it isn't a nice way to do it, but no problems in 20k of miles. It keeps at about an inch from the coil




Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
16 Posts
Discussion Starter #10
Fixed and thanks again

Just confirming that it was the problem. All problems gone with steering wheel centered. Thanks again. Here is what it looks like with the 2.5 inch lift kit installed.
 

Attachments

·
I AM THERE4 I JEEP
Joined
·
12,295 Posts
Just confirming that it was the problem. All problems gone with steering wheel centered. Thanks again. Here is what it looks like with the 2.5 inch lift kit installed.
:thumb:
 

·
Registered
Joined
·
578 Posts
Looks good. Any rubbing or did you use wheel spacers?


Sent from my iPhone using Tapatalk
 
1 - 12 of 12 Posts
Top