Jeep Wrangler Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
My radio will start with the Jeep logo, but that's as far as it will go. It should move on to the "Accept" screen and then I should be able to use it like normal. However, after about 45 secs, the radio will completely shutdown and power back up again and start the whole cycle over. I have a 2016 so I can bring it to the dealer, but I am hoping someone knows a quick fix and I can avoid that whole situation. Any help would be greatly appreciated. Thanks!
 

·
Registered
Joined
·
2,468 Posts
Try disconnecting the battery for a few minutes. Reconnect and see if the radio resets. If it doesn't, you'll have to head back to your dealer.
 

·
Premium Member
Joined
·
6,739 Posts
I am not sure about the radio, but in computers, that is a classic sign of a failing power supply, it starts up but there is insufficient power to finish initialization (boot in computer terms) so it shuts down but still has the start sequence in queue so it does it over and over.

If disconnecting the battery does not work, have the battery and charging system checked at a reputable auto parts. Normally they will check that for free.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #5
I am not sure about the radio, but in computers, that is a classic sign of a failing power supply, it starts up but there is insufficient power to finish initialization (boot in computer terms) so it shuts down but still has the start sequence in queue so it does it over and over.

If disconnecting the battery does not work, have the battery and charging system checked at a reputable auto parts. Normally they will check that for free.
I hope that it's nothing serious as I've only had it now for 2 weeks. Didn't get a chance last night to disconnect my battery as my roommate and I were working on his BMW. I will let you know what happens. Thanks.
 

·
Registered
Joined
·
247 Posts
It's a 2016 take it to the dealer... Speaking of BMWs I had this happen on mine (out of warranty). The radio nav screen would start to boot with the BMW symbol then go black after a while and try to do it all over again. The Car Communication Computer (CCC) ended up being bad and replaced it at the tune of $2k.
 

·
Registered
Joined
·
461 Posts
Take it to the dealer they should replace it. I just got mine replaced, and seems like there is quite a few members on here that have had theirs replaced as well.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #8
It's going to the dealer Thursday morning as disconnecting the battery did not work. I appreciate all the input though.
 
1 - 8 of 8 Posts
Top