Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
499 Posts
Discussion Starter · #1 ·
hey guys I am currently installing the Big Brake Kit from Vanco and the instructions told me to remove the hub assembly and the axle shafts. So I did. Then as I put the axle shaft back in i notice something is blocking it. I get a flashlight and look down the axle tube and I notice a little ring blocking the way? The passenger side of the axle, it is down there a good bit. I can pull it out with a magnet stick if I have to. On the drivers side it came right out. as you can see in the pictures. I have a dana 30. What are these little rings? How do I re-install it correctly? Thanks!

This is what came out of the drivers side axle tube




Now this is the picture of the passenger side. As you can see that little ring is way down that tube.



 

·
Registered
Joined
·
499 Posts
Discussion Starter · #3 ·
Okay I got it by making a hook out of a closet hangar. Now how do I put them back on correctly? Does it go like this on the axle shaft?
 

Attachments

·
Registered
Joined
·
1,808 Posts
Okay I got it by making a hook out of a closet hangar. Now how do I put them back on correctly? Does it go like this on the axle shaft?
Looks like they are small "seals" to keep big debris out of the tubes. Other then that I cant think of a use for them being there.
 

·
Knows a couple things...
Joined
·
49,383 Posts
That's just an assembly piece to help keep the axle shaft centered while being inserted. It's not needed at all, I haven't had one of those in my TJ in probably 12 years.
 
1 - 5 of 5 Posts
Top