Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
119 Posts
Discussion Starter · #1 ·
So I just finished wiring up my KC lights (they work great), but my radio doesn't work anymore.. I checked the fuse under the dash labeled "radio", and it looks good still. I also looked at the one in my head unit, it looks good as well. I checked for loose wires.. nothing.

Is there anything else that could have caused my radio to stop working? I'm running to Canadian Tire right now to get new fuses even though the ones in there looked fine. You never know.

Any suggestions would be greatly appreciated!
 

·
Registered
Joined
·
119 Posts
Discussion Starter · #2 ·
Oh, everything else is working fine! All my gauges, and lights, and other electrical stuff work fine.
 

·
Registered
Joined
·
119 Posts
Discussion Starter · #3 ·
I don't know to much about relays, but this could have caused the issue.. My KC lights came with a relay, and I got it installed and everything.. Should that relay be screwed into the firewall of the Jeep (for grounding)? Or is it alright if I just keep it held on with two sided tape? Would that have caused any issues?
 

·
Mostly old school..!
Joined
·
12,149 Posts
I don't know to much about relays, but this could have caused the issue.. My KC lights came with a relay, and I got it installed and everything.. Should that relay be screwed into the firewall of the Jeep (for grounding)? Or is it alright if I just keep it held on with two sided tape? Would that have caused any issues?
It doesn't matter how the relay is mounted...it has a separate ground. Check your radio fuse with a meter or replace it with a known good fuse. Sometimes you can't tell by looking. If it is an after market radio, see if there is an additional in line fuse.
 
1 - 5 of 5 Posts
Top