Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 6 of 6 Posts

·
Registered
Joined
·
1,051 Posts
Discussion Starter · #1 ·
Ok so I installed an Isuzu rodeo rear end in my YJ two months ago just got the new rear driveshaft installed last week.

Did the nutter today and take it for a test drive and as I pull back in the driveway it feels as though it is fighting to go forward goes in reverse fine but forward it is like the e brake is on but I obviously released to take the test drive.

So what gives here?

I jacked up the rear and wheels spun backwards but forwards not at all.

On a side note the nutter bypass worked fine
Course fat lot of good it did now no forward!

Chief
 

·
Registered
Joined
·
1,272 Posts
if its not the parking brake I'd remove the drums and check the brakes. then with the drums off try to turn it again. if it still won't turn its something in the rear end.
 

·
Registered
Joined
·
1,051 Posts
Discussion Starter · #5 ·
You guys were correct it is not the brakes took them apart and looked at them as well as e-brake.

Turned out to be the pinion nut was loose I either did not torque it to begin with or torqued in correctly.

Tightened it to 180lbs

Test drive up and down the block no problems no issues no grinding sounds thank goodness!

Man I would have freaked if I had blown my new rear end

Thanks for the help guys
 

·
Registered
Joined
·
332 Posts
Congrats on the swap!! I'm still planning on getting you some info on my D44 front axle as soon as get in there and start pulling things apart.
 
1 - 6 of 6 Posts
Top