Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!
1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
93 2.5 5spd. Rockers sound like a bunch of rocks under the cover and I'm thinking i can just replace the rockers and push rods. Any help advice experiences would be appreciated
 

·
Super Moderator
Joined
·
12,929 Posts
My first thought is poor oil pressure.
Next thought is bad lifters.
Buy a good valve cover gasket and then pull the cover. It might be something has come loose and all that is needed is to tighten it back up.
Do you have the stock oil pressure gauge or have you installed a mechanical gauge? What is your oil pressure at idle and at speed?

Good Luck, L.M.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Good pressure damn near pegged. Quiet as a mouse when first started, starts getting up to temp and it literary sounds like rocks under there lol. Oh yea plenty of power, not getting hot or anything else. Can the rockers and push rods be replaced?
 

·
Registered
Joined
·
398 Posts
Mine does something similar. Starts quiet and after 20 seconds starts making those sounds you described. As soon as it warms up the sounds go away. Good pressure and great power.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Mine is quiet on start up but as soon as the temp gauge begins to move the noise starts. Any of you guys on here have any ideas? A lot of 2.5s I've seen have the same sound but mine is just louder than most.
 
1 - 5 of 5 Posts
Top