Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 7 of 7 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
Me and a friends of mine put a 3.25 inch lift with performance 2.2 shocks.. Well my issue is they say the drag link MUST be adjusted and we adjusted it..(even though they weren't but a 16th of an inch off) Now my traction control is blinking and the brakes are acting as if I'm sliding.. Any help?
 

·
Premium Member
Joined
·
1,221 Posts
You need to make sure your steering wheel is straight when your going straight. If your steering wheel is off that will happen. You need to adjust your drag link till your steering wheel is straight. Mine did the same thing till I adjusted it.
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #3 ·
You need to make sure your steering wheel is straight when your going straight. If your steering wheel is off that will happen. You need to adjust your drag link till your steering wheel is straight. Mine did the same thing till I adjusted it.
But after it's adjusted that will quit? I'm putting my wheels and tires on tomorrow after work so i can adjust it straight tomorrow, thanks alot!
 

·
I AM THERE4 I JEEP
Joined
·
12,295 Posts
To clarify.

The ESP is showing on the dash while the jeep is not in motion without wheels/tires? If so you may have damaged one of the sensors in the wheels during the lift install. The computer wouldn't activate the program while the jeep was stationary.

If the jeep is moving and your experiencing this, it could still be a damaged sensor but more likely the collar on the drag link (to center the steering wheel) needs adjusting. 3.25" is pretty high and can change the way the computer feels about the ESC program.

What are you toe numbers?
 

·
Premium Member
Joined
·
1,221 Posts
Yes, It will go away once your steering wheel is back to straight when you are going straight.
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #6 ·
We got it straight last night, but it took awhile for it to clear but it finally did last night headed back into town
 
1 - 7 of 7 Posts
Top