Wrangler Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My 2015 JKU has been running hot recently as the temps here in North Texas have started to rise. The temp gauge is normally in the middle but now it will fluctuate to between the middle and the H but never getting more than 3/4 to the H. The fan is also running constantly when it warms up.

I checked the coolant level and it was low so I serviced with the overpriced Mopar antifreeze but it has not fixed the problem.

In January I got a check engine light with a P128 which has something to do with the thermostat but I thought i meant it was stuck open.

The only mods I have to the engine is the Super Tuner I am running with the 93 octane boost but thats been 2 years now with no problems.

I was either going to flush or change the thermostat and flush. Just wondering if anyone else has had this problem.
 

·
Premium Member
Joined
·
3,623 Posts
The thermostat is a cheap part, so if you're going to flush your coolant, change the thermostat at the same time.

Are you sure you have no coolant leak?
 

·
RETIRED MODERATER
Joined
·
34,851 Posts
1. Do you have something (winch, lights, grill inserts) blocking air flow to your radiator?

2. Also check your coolant level in the Radiator when cold. Coolant leak maybe.

3. Install a new Radiator cap.

4. Blow out the rubber hose between the Radiator cap and overflow bottle.

5. Remove your overflow bottle and flush out all of the crap in it. It will look like mud.

6. Refill the overflow bottle with OAT 50/50 mixed antifreeze, but only fill it to approx. 1" above the minimum mark when cold.

7. Remove the Radiator cover support, 4 pins. Then flush out your radiator externally with a water hose.

I would give this a try first. If still running hot, then new thermostat and coolant flush.
 
1 - 3 of 3 Posts
Top