Jeep Wrangler Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hey guys

I have a 2016 Jeep Wrangler Sport with 7,400 miles on it. Only got it 2 months ago (do a lot of commuting).

Today I got an oil change & multi point inspection at the dealer, drove to and from work (18 miles round trip). Was turning right at about 8 mph and then my check engine light came on, and my car just engine just shut off. Everything electronically was still on- gas tank was full, correct time, correct speed (obviously now going at about 0 mph at this point). If I took my foot off the brake, car would roll backwards and no matter how hard I pressed down on the gas wouldn't go forward at all (engine totally shut off).

Put the car in park and shut it off. Turned it back on and no check engine light and car worked totally fine.

Anyone have any suggestions?
 

·
Registered
Joined
·
243 Posts
Do you know about the key dance to check for stored codes?

From off, turn the key to on three times (without going all the way to start), and leave it in the on position. You should get a read out of stored codes on the odometer display, ending in -------.
 

·
Registered
Joined
·
13 Posts
Mine just recently started doing the same thing. I get random cylinder misfire codes, camshaft position sensor codes, and sometimes there is no code when it happens or the code(s) just disappear. The dealer can't check it out till Jan 3rd, but in the mean time I filed a complaint with the NHTSA as a safety issue
 
1 - 7 of 7 Posts
Top