Jeep Wrangler Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 6 of 6 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Looking to see if someone has a suggestion for a quick fix. All my other lights are working. The turn signals are working, but the sidemarkers (on the fender flare) are not. I assume a fuse, but thought they would be on the same circuit as the turn signals.
 

·
Premium Member
Joined
·
7,920 Posts
you check grounds-wiring good to socket/bulbs? idk thought it would run same route wiring as blinker on front off fender?
 

·
Registered
Joined
·
3,755 Posts
Looking to see if someone has a suggestion for a quick fix. All my other lights are working. The turn signals are working, but the sidemarkers (on the fender flare) are not. I assume a fuse, but thought they would be on the same circuit as the turn signals.
I do not think these run on the same circuit as the turn signals but more likely the running lights. Have you checked the bulbs and grounds?
 

·
Premium Member
Joined
·
1,893 Posts
The sockets they used for the bulbs are kinda cheap and they don't seal very well. After awhile water will corrode the small contacts inside the socket, the easiest way to fix them is to make sure you actually have power to the socket, then just cut the old ones out and replace the socket and bulb. Almost all part stores will carry the exact type of socket you will need.
 

·
Registered
Joined
·
36 Posts
I had one stop working. Not only was my socket full of crap I have a slight crack on the yellow reflector, letting in a little moisture. So, I cleaned out the socket and went to buy a new bulb, but didn't have enough money on me to get it right then ($4.95 for two little bulbs from China?! I only had three on me. :) ). So I put the old bulb back in to keep the socket clean and the bulb came on. I really thought that I had seen the element open, but apparently was mistaken.

Those sockets are in a great location to get covered with all kinds of crap and putting new/better ones in sounds like a great idea. I hadn't thought of that, for some reason.


Merry Christmas... RT
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #6 ·
Thanks for the input. I checked fuses and connections. Think I'll give the cleaning a try next. I don't think that's it because both are out, but won't know til I try.
 
1 - 6 of 6 Posts
Top